Details

    • Type: Task Task
    • Status: Closed
    • Priority: Trivial Trivial
    • Resolution: Fixed
    • Affects Version/s: 1.4.1-incubating
    • Fix Version/s: None
    • Component/s: connectors/oracle
    • Labels:
      None
    • Environment:

      Linux

      Description

      While trying to connect using the Oracle JDBC URL getting errors

      sqoop import --connect jdbc:oracle:thin:@myhose:myport/SID --username scott --password tiger --driver oracle.jdbc.driver.OracleDriver --table=TEST_SQOOP

      INFO manager.SqlManager: Using default fetchSize of 1000
      12/03/08 15:51:14 INFO tool.CodeGenTool: Beginning code generation
      12/03/08 15:51:15 INFO manager.SqlManager: Executing SQL statement: SELECT t.* FROM TEST_SQOOP AS t WHERE 1=0
      12/03/08 15:51:15 ERROR manager.SqlManager: Error executing statement: java.sql.SQLSyntaxErrorException: ORA-00933: SQL command not properly ended

      java.sql.SQLSyntaxErrorException: ORA-00933: SQL command not properly ended

      at oracle.jdbc.driver.T4CTTIoer.processError(T4CTTIoer.java:445)

      I read and understood this issue is fixed via SQOOP 317 but still it doesnt work for me. This table test_scoop is created in the default user schema.

      Please help

      sqoop version
      Sqoop 1.4.1-incubating
      git commit id
      Compiled by jarcec on Tue Feb 7 20:46:19 CET 2012

        Issue Links

          Activity

          Kathleen Ting added a comment - - edited

          @sathish - As it happens, by explicitly specifying the driver oracle.jdbc.driver.OracleDriver, the impact is the opposite of your intent. That is, when the driver option is included in the Sqoop command, the built-in connection manager selection defaults to the generic connection manager, which is not your intended Oracle driver. This is because by default, the built-in Oracle connection manager will chose the very driver you are trying to pass in. As a result, please remove the option "driver oracle.jdbc.driver.OracleDriver" and then re-run your Sqoop command. Once you've verified your command works, please close this JIRA as not a bug. Going forward, for faster response, please post user-related questions to sqoop-user@incubator.apache.org. Thanks.

          sathish added a comment -

          Thanks kathleen. This fixed the issue.

          sqoop import --connect jdbc:oracle:thin:@host:port/SID --username user --password pass --table EXAMPLE.TESTING_SQOOP

          As you mentioned the issue is by specifying the driver.

          sathish added a comment -

          Issue is resolved.

          Kathleen Ting added a comment -

          @sathish - Since this is not a bug, please reopen the JIRA and update the resolution to "not-a-bug" for tracking purposes. Thanks.

          Abhijeet Gaikwad added a comment -

          Removing fix version as this is not a bug.
          Further, this JIRA should be marked "not a bug". This is pending till reporter does that or some workaround is found.


            People

            • Assignee:
              Kathleen Ting
              Reporter:
              sathish
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development