Uploaded image for project: 'Sqoop'
  1. Sqoop
  2. SQOOP-2135

Sqoop2: Add direction to the uniqueness that is verified for config names

    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: Open
    • Priority: Major
    • Resolution: Unresolved
    • Affects Version/s: 1.99.5
    • Fix Version/s: 2.0.0
    • Component/s: None
    • Labels:
      None

      Description

      As part of From/To changes in 1.99.4, we've added constraint in our repository that combination of config name, type and configurable needs to be unique (where type is either job or link).

      As we are having different configuration objects for both FROM and TO directions and the direction specification is not part of the unique key, it means that one can't have the same input name for both direction. For example instead of:

      class FromConfig {
       String table;
      }
      
      class ToConfig {
       String table;
      }
      

      We have to rename the variables to be unique:

      class FromConfig {
       String fromTable;
      }
      
      class ToConfig {
       String toTable;
      }
      

      This is troublesome because:

      • We're requesting uniqueness across different classes.
      • We have to rename variables to a longer then necessary names.
      • This limitation is not checked by java as it's verified in repository (e.g. no compilation errors, only runtime checks).

      Hence I would suggest to allow that back

        Attachments

          Activity

            People

            • Assignee:
              Unassigned
              Reporter:
              jarcec Jarek Jarcec Cecho
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated: