Uploaded image for project: 'Sqoop'
  1. Sqoop
  2. SQOOP-1579

Sqoop2: Data transfer to load into Hive does not work

    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 1.99.6
    • Component/s: sqoop2-hdfs-connector
    • Labels:
      None

      Description

      When we import many columns(say >20 columns) from RDBMS to HDFS, then Sqoop2 inserts a new line in the output file.The newline appears at the end of certain columns.Doesn't seem to appear for every single column.
      When we try to view this data in Hive, it shows NULL at the new line separator in it.
      As per Abraham,this looks like a problem with unescaping the data.

        Attachments

        1. SQOOP-1579.0.patch
          22 kB
          Abraham Elmahrek
        2. SQOOP-1579.1.patch
          62 kB
          Abraham Elmahrek
        3. SQOOP-1579.2.patch
          63 kB
          Abraham Elmahrek
        4. SQOOP-1579.3.patch
          52 kB
          Abraham Elmahrek
        5. SQOOP-1579.4.patch
          54 kB
          Abraham Elmahrek
        6. SQOOP-1579.5.patch
          53 kB
          Abraham Elmahrek
        7. SQOOP-1579.6.patch
          52 kB
          Abraham Elmahrek

          Issue Links

            Activity

              People

              • Assignee:
                abec Abraham Elmahrek
                Reporter:
                shakun Shakun Grover
              • Votes:
                0 Vote for this issue
                Watchers:
                7 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: