Details

    • Type: Sub-task Sub-task
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 1.4.5
    • Component/s: connectors/oracle
    • Labels:
      None

      Description

      As part of donating the data connector - Dell would like to perform QA before it is released.
      This should be started on the 16th July.

        Activity

        Vidya Iyengar added a comment - - edited

        Testing Summary:
        ==============
        Tested using " sqoop-1.4.5-SNAPSHOT.bin__hadoop-2.0.4-alpha.tar.gz " on CDH4 (melhadoop01).
        Unzipped the file to a folder and
        Downloaded and Copied odbc6.jar file as mentioned in the user guide and copied to the relevant folder.
        Modified path of the Sqoop to the current one (sqoop 1.4.5).

        Ran basic import and Export (user creates export table)on few different tables using melintdbw90a db (tfh_userr1).
        Since Davids automation test covers import feature, manual testing was mainly focused on Export feature.
        Ran all the 15 export cases from Guy Ley Mar document on SASDB01.
        All the export cases passed except Case 13, Raised a bug.
        https://issues.apache.org/jira/browse/SQOOP-1388

        Enabled trace via oroop_template.xml files and tested these
        Confirmed trace are written on Oracle db after running a job, "Oaoop.block.allocation", "oraoop.table.import.where.clause.location:SPLIT".

        Tested Basic import and export on RAC instance melvsxspotl133:1521/spotl133 (10.20.29.15). Confirmed Exported data is correct.

        Checked the User guide (html) ,Noticed few Sqoop commands in the examples are missing --direct switch. Apart from this did not notice any major issues.

        Abraham Elmahrek added a comment -

        Vidya,

        Which examples are missing the --direct switch in particular?

        Also, thank for doing this testing!

        Vidya Iyengar added a comment -

        Abraham,
        In the following sections of the HTML document, “¬--direct” switch is missing for SQOOP command line examples.
        24.8.7.3
        24.8.7.10
        24.8.7.12
        24.8.8.1
        24.8.8.2

        Abraham Elmahrek added a comment -

        Vidya, I don't see these sections in the documentation.

        Are you done with your testing? If so, can we close this Jira?

        Vidya Iyengar added a comment -

        I'm done with testing , will close the item.


          People

          • Assignee:
            Vidya Iyengar
            Reporter:
            David Robson
          • Votes:
            0 Vote for this issue
            Watchers:
            4 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Time Tracking

              Estimated:
              Original Estimate - 48h
              48h
              Remaining:
              Remaining Estimate - 48h
              48h
              Logged:
              Time Spent - Not Specified
              Not Specified

                Development