Sqoop
  1. Sqoop
  2. SQOOP-1305

Please create a DOAP file for your TLP

    Details

    • Type: Task Task
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: no-release
    • Component/s: None
    • Labels:
      None

      Description

      As per my recent e-mail to your dev list, please can you set up a DOAP for your project and get it added to files.xml?

      Please see http://projects.apache.org/create.html

      Once you have created the DOAP and committed it to your source code repository, please submit it for inclusion in the Apache projects listing as per:

      http://projects.apache.org/create.html#submit

      Remember, if you ever move or rename the doap file in future, please
      ensure that files.xml is updated to point to the new location.

      Thanks!

      1. doap_Sqoop.rdf
        3 kB
        Jarek Jarcec Cecho
      2. doap_Sqoop.rdf
        3 kB
        Jarek Jarcec Cecho

        Activity

        Jarek Jarcec Cecho added a comment -

        Thank you Sebb.

        Sebb added a comment -

        URL: http://svn.apache.org/r1630746
        Log:
        SQOOP-1305 += Sqoop

        Modified:
        infrastructure/site-tools/trunk/projects/files.xml

        Jarek Jarcec Cecho added a comment -

        Good catch Sebb. I've refreshed the file, could you try it out now?

        Sebb added a comment -

        Unfortunately the RDF is not well-formed - I get the following when trying to view it in FireFox.

        XML Parsing Error: not well-formed
        Location: http://sqoop.apache.org/doap/doap_Sqoop.rdf
        Line Number 33, Column 59: <download-page rdf:resource="http://sqoop.apache.org/"" />

        Please fix.

        Sebb added a comment -

        Huh? Why is it weird to send an e-mail (not spam) a mailing list?
        That's basically what creating a JIRA issue does - it "spams" the project issues mailing list, where a human can read and process the issue.

        However the process in this case is very simple so there's no need for the overhead of a JIRA issue.

        Just to confirm: sending the email is the correct process, unless the PMC chair or an ASF member on the PMC is able to do it.

        In this case, I will do it.

        Jarek Jarcec Cecho added a comment -

        Hmm... I would expect that there will be some web form where we will enter the final public URL. Instead, the instructions seem to be suggesting to spam some mailing list so that a human being can manually apply changes. Seems weird to me, so I wanted to ensure that it's indeed the right process, Sebb?

        Jarek Jarcec Cecho added a comment -
        Jarek Jarcec Cecho added a comment -

        Yeah, I guess we will have to go with the SVN version rather then Git as there is something wrong with the UI. I don't think that it's a GIT thing. I'm able to correctly checkout HEAD of doap branch and everything is working as I would expect.

        Hence, I've removed the doap branch to not have the same file on several locations and uploaded to the SVN tree:

        http://sqoop.staging.apache.org/doap/doap_Sqoop.rdf

        Sebb added a comment -

        Looks like the DOAP is not in the git HEAD, but I've no idea what the problem is, except it is likely to be a problem with the way the file was added rather than an issue with the ASF Git UI.

        As I wrote earlier, you may find it easier to add the DOAP somewhere under the SVN tree which the project uses for its website.

        Jarek Jarcec Cecho added a comment -

        Sebb I'm hitting bug in ASF Infra GitWeb UI. When you open following page with the doap file which is my commit and then following link HEAD to get from the commit to head of the branch, I'm getting "404 Can't fine file".

        Venkat Ranganathan added a comment -

        +1. Sorry, I thought I commented on it before, but it looks like I missed. Thanks for putting it together Jarek Jarcec Cecho.

        Jarek Jarcec Cecho added a comment -

        Venkat Ranganathan or Abraham Elmahrek, could you take a look at the proposed DOAP file?

        Sebb added a comment -

        PING

        Sebb added a comment -

        Note that the URL as above is suitable for use with the project site builder.

        It needs to return the raw blob contents.
        Also, it looks like the Git URL is for a specific version of the DOAP; it needs to point to the current version.

        Here is a valid example:

        https://git-wip-us.apache.org/repos/asf?p=archiva.git;f=doap_Archiva.rdf;a=blob_plain;hb=HEAD

        As mentioned previously, it may be easier to keep the DOAP in the SVN tree used for the site; it can then be referenced using a URL like

        http://sqoop.apache.org/optionalPath/doap_Sqoop.rdf

        Jarek Jarcec Cecho added a comment -

        I've also committed the file to a special doap branch as suggested earlier and the file is available here. I'll wait with submitting the location to Infra for other committer to +1 the changes.

        Jarek Jarcec Cecho added a comment -

        Attaching new version of the doap file.

        Changes:

        • Added Git repository instead of SVN one
        • Added latest release
        Sebb added a comment -

        The form does now support Git.

        Please can someone generate the DOAP and store it somewhere, then ensure that the file is included in the projects site.

        Sebb added a comment -

        Even though the form does not (yet) support Git, it's trivial to edit the DOAP fix this.

        Please can you add the corrected DOAP a public URL so the project site files.xml can be updated.

        Sebb added a comment -

        Or it looks like you could use the generic <Repository>

        Jarek Jarcec Cecho added a comment -

        Agreed that the SVNRepository seems weird - sadly the form don't have ability to choose Git as a repository.

        Sebb added a comment -

        The tag <SVNRepository> is not ideal for use with Git ... Please use <GitRepository> instead.

        I agree the DOAP is probably best not stored with the main code - it is not included in source archives and it does not really need to be tagged either.

        You might also be able to store it in the SVN repo which is used to hold the site files.
        Some projects include a link to the DOAP on their website.

        Jarek Jarcec Cecho added a comment -

        Would be great if others can take a look and confirm validity of the file.

        Considering that outside of Apache the file is pretty much useless and that it have to be somewhere in Git, I would suggest to commit it into separate doap branch and maintain it there. Any thoughts?

        Jarek Jarcec Cecho added a comment -

        Attaching generated DOAP (*.rdf) file.

        Jarek Jarcec Cecho added a comment -

        I've tried it long time ago and to be honest I got very frustrated as the basic infrastructure hasn't been working as I was getting random exceptions all over the place. It seems that the associated JIRA INFRA-6691 has been resolved since then, so I'll try to take a look.

        Sebb added a comment -

        Can someone take a look at this please?

        Sebb added a comment -

        PING


          People

          • Assignee:
            Jarek Jarcec Cecho
            Reporter:
            Sebb
          • Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development