Sqoop
  1. Sqoop
  2. SQOOP-1208

Sqoop2: job ID column is too small

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 1.99.2
    • Fix Version/s: 1.99.4
    • Component/s: sqoop2-framework
    • Labels:
      None

      Description

      Caused by: java.sql.SQLDataException: A truncation error was encountered trying to shrink VARCHAR 'job_20130926111336541_0001' to length 25.
              at org.apache.derby.impl.jdbc.SQLExceptionFactory40.getSQLException(Unknown Source)
              at org.apache.derby.impl.jdbc.Util.generateCsSQLException(Unknown Source)
              at org.apache.derby.impl.jdbc.TransactionResourceImpl.wrapInSQLException(Unknown Source)
              at org.apache.derby.impl.jdbc.TransactionResourceImpl.handleException(Unknown Source)
              at org.apache.derby.impl.jdbc.EmbedConnection.handleException(Unknown Source)
              at org.apache.derby.impl.jdbc.ConnectionChild.handleException(Unknown Source)
              at org.apache.derby.impl.jdbc.EmbedStatement.executeStatement(Unknown Source)
              at org.apache.derby.impl.jdbc.EmbedPreparedStatement.executeStatement(Unknown Source)
              at org.apache.derby.impl.jdbc.EmbedPreparedStatement.executeUpdate(Unknown Source)
              at org.apache.commons.dbcp.DelegatingPreparedStatement.executeUpdate(DelegatingPreparedStatement.java:105)
              at org.apache.commons.dbcp.DelegatingPreparedStatement.executeUpdate(DelegatingPreparedStatement.java:105)
              at org.apache.commons.dbcp.DelegatingPreparedStatement.executeUpdate(DelegatingPreparedStatement.java:105)
              at org.apache.sqoop.repository.derby.DerbyRepositoryHandler.createSubmission(DerbyRepositoryHandler.java:1197)
              ... 25 more
      
      1. SQOOP-1208.1.patch
        5 kB
        Abraham Elmahrek
      2. SQOOP-1208.patch
        0.8 kB
        Abraham Elmahrek

        Issue Links

          Activity

          Abraham Elmahrek added a comment - - edited

          I think it should be 50 I think. Yarn has a job id of "application_<timestamp>_<5 digit number>", which should be longer than MR1.

          Sqoop QA bot added a comment -

          Here are the results of testing the latest attachment
          https://issues.apache.org/jira/secure/attachment/12605322/SQOOP-1208.patch against branch sqoop2.

          Overall: -1 due to an error

          ERROR: Patch does not add/modifny any test case
          SUCCESS: Clean was successful
          SUCCESS: Patch applied correctly
          SUCCESS: Patch compiled
          SUCCESS: All tests passed

          Console output: https://builds.apache.org/job/PreCommit-SQOOP-Build/157/console

          This message is automatically generated.

          Sqoop QA bot added a comment -

          Here are the results of testing the latest attachment
          https://issues.apache.org/jira/secure/attachment/12606193/SQOOP-1208.1.patch against branch sqoop2.

          Overall: +1 all checks pass

          SUCCESS: Clean was successful
          SUCCESS: Patch applied correctly
          SUCCESS: Patch add/modify test case
          SUCCESS: Patch compiled
          SUCCESS: All tests passed

          Console output: https://builds.apache.org/job/PreCommit-SQOOP-Build/159/console

          This message is automatically generated.

          ASF subversion and git services added a comment -

          Commit 0a5a80cbfaa92c9acf87b125831ed92451b86050 in branch refs/heads/sqoop2 from Jarek Jarcec Cecho
          [ https://git-wip-us.apache.org/repos/asf?p=sqoop.git;h=0a5a80c ]

          SQOOP-1208: Sqoop2: job ID column is too small

          Jarek Jarcec Cecho added a comment -

          Thank you Abraham Elmahrek for your contribution!

          Hudson added a comment -

          SUCCESS: Integrated in Sqoop2-hadoop200 #516 (See https://builds.apache.org/job/Sqoop2-hadoop200/516/)
          SQOOP-1208: Sqoop2: job ID column is too small (jarcec: https://git-wip-us.apache.org/repos/asf?p=sqoop.git&a=commit&h=0a5a80cbfaa92c9acf87b125831ed92451b86050)

          • repository/repository-derby/src/test/java/org/apache/sqoop/repository/derby/DerbyTestCase.java
          • repository/repository-derby/src/main/java/org/apache/sqoop/repository/derby/DerbySchemaQuery.java
          • repository/repository-derby/src/main/java/org/apache/sqoop/repository/derby/DerbyRepositoryHandler.java
          • repository/repository-derby/src/main/java/org/apache/sqoop/repository/derby/DerbyRepoConstants.java
          Hudson added a comment -

          SUCCESS: Integrated in Sqoop2-hadoop100 #583 (See https://builds.apache.org/job/Sqoop2-hadoop100/583/)
          SQOOP-1208: Sqoop2: job ID column is too small (jarcec: https://git-wip-us.apache.org/repos/asf?p=sqoop.git&a=commit&h=0a5a80cbfaa92c9acf87b125831ed92451b86050)

          • repository/repository-derby/src/main/java/org/apache/sqoop/repository/derby/DerbyRepositoryHandler.java
          • repository/repository-derby/src/test/java/org/apache/sqoop/repository/derby/DerbyTestCase.java
          • repository/repository-derby/src/main/java/org/apache/sqoop/repository/derby/DerbySchemaQuery.java
          • repository/repository-derby/src/main/java/org/apache/sqoop/repository/derby/DerbyRepoConstants.java

            People

            • Assignee:
              Abraham Elmahrek
              Reporter:
              Abraham Elmahrek
            • Votes:
              0 Vote for this issue
              Watchers:
              5 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development