Sqoop
  1. Sqoop
  2. SQOOP-1069

Sqoop2: Incorrect error message from FrameworkValidator

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 1.99.2
    • Fix Version/s: 1.99.3
    • Component/s: sqoop2-framework
    • Labels:
      None

      Description

      In org.apache.sqoop.framework.FrameworkValidator.java, there is a piece of code:

        private void validateOutputForm(Validation validation, OutputForm output) {
          if(output.outputDirectory == null || output.outputDirectory.isEmpty()) {
            validation.addMessage(Status.UNACCEPTABLE, "output", "outputDirectory", "Input directory is empty");
          }
        }
      

      The error message should be "Output directory is empty".

      1. SQOOP-1069.1.patch
        0.8 kB
        Mengwei Ding

        Activity

        Mengwei Ding created issue -
        Mengwei Ding made changes -
        Field Original Value New Value
        Attachment SQOOP-1069.1.patch [ 12586614 ]
        Mengwei Ding made changes -
        Status Open [ 1 ] In Progress [ 3 ]
        Mengwei Ding added a comment -

        Patch uploaded.

        Mengwei Ding made changes -
        Status In Progress [ 3 ] Patch Available [ 10002 ]
        Jarek Jarcec Cecho made changes -
        Summary Incorrect error message from FrameworkValidator Sqoop2: Incorrect error message from FrameworkValidator
        Description In org.apache.sqoop.framework.FrameworkValidator.java, there is a piece of code:

          private void validateOutputForm(Validation validation, OutputForm output) {
            if(output.outputDirectory == null || output.outputDirectory.isEmpty()) {
              validation.addMessage(Status.UNACCEPTABLE, "output", "outputDirectory", "Input directory is empty");
            }
          }

        The error message should be "Output directory is empty".
        In {{org.apache.sqoop.framework.FrameworkValidator.java}}, there is a piece of code:

        {code}
          private void validateOutputForm(Validation validation, OutputForm output) {
            if(output.outputDirectory == null || output.outputDirectory.isEmpty()) {
              validation.addMessage(Status.UNACCEPTABLE, "output", "outputDirectory", "Input directory is empty");
            }
          }
        {code}
        The error message should be "Output directory is empty".
        ASF subversion and git services added a comment -

        Commit 662f18a0a3db9fa760892f67b16c001f47b7332d in branch refs/heads/sqoop2 from Jarek Jarcec Cecho
        [ https://git-wip-us.apache.org/repos/asf?p=sqoop.git;h=662f18a ]

        SQOOP-1069: Sqoop2: Incorrect error message from FrameworkValidator

        (Mengwei Ding via Jarek Jarcec Cecho)

        Jarek Jarcec Cecho added a comment -

        Thank you Mengwei for your contribution!

        Jarcec

        Jarek Jarcec Cecho made changes -
        Status Patch Available [ 10002 ] Resolved [ 5 ]
        Resolution Fixed [ 1 ]
        Hudson added a comment -

        Integrated in Sqoop2-hadoop200 #313 (See https://builds.apache.org/job/Sqoop2-hadoop200/313/)
        SQOOP-1069: Sqoop2: Incorrect error message from FrameworkValidator (Revision 662f18a0a3db9fa760892f67b16c001f47b7332d)

        Result = FAILURE
        jarcec : https://git-wip-us.apache.org/repos/asf?p=sqoop.git&a=commit&h=662f18a0a3db9fa760892f67b16c001f47b7332d
        Files :

        • core/src/main/java/org/apache/sqoop/framework/FrameworkValidator.java
        Hudson added a comment -

        Integrated in Sqoop2-hadoop100 #308 (See https://builds.apache.org/job/Sqoop2-hadoop100/308/)
        SQOOP-1069: Sqoop2: Incorrect error message from FrameworkValidator (Revision 662f18a0a3db9fa760892f67b16c001f47b7332d)

        Result = SUCCESS
        jarcec : https://git-wip-us.apache.org/repos/asf?p=sqoop.git&a=commit&h=662f18a0a3db9fa760892f67b16c001f47b7332d
        Files :

        • core/src/main/java/org/apache/sqoop/framework/FrameworkValidator.java
        Jarek Jarcec Cecho added a comment -

        The failure is again caused by memory issues on Jenkins...

        Mengwei Ding made changes -
        Affects Version/s 1.99.2 [ 12323640 ]
        Affects Version/s 1.99.1 [ 12323641 ]

          People

          • Assignee:
            Mengwei Ding
            Reporter:
            Mengwei Ding
          • Votes:
            0 Vote for this issue
            Watchers:
            4 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development