Details

    • Type: Bug
    • Status: Resolved
    • Priority: Trivial
    • Resolution: Fixed
    • Affects Version/s: 1.99.2
    • Fix Version/s: 1.99.3
    • Component/s: None
    • Labels:
      None

      Description

      I've created connection without name and displayed it with TableDisplayer which lead to following NPE:

      sqoop:000> show connection                       
      Exception has occurred during processing command 
      Exception: java.lang.NullPointerException Message: null
      Stack trace:
               at  org.apache.sqoop.client.utils.TableDisplayer (TableDisplayer.java:109)  
               at  org.apache.sqoop.client.utils.TableDisplayer (TableDisplayer.java:49)  
               at  org.apache.sqoop.client.shell.ShowConnectionFunction (ShowConnectionFunction.java:79)  
               at  org.apache.sqoop.client.shell.ShowConnectionFunction (ShowConnectionFunction.java:55)  
               at  org.apache.sqoop.client.shell.SqoopFunction (SqoopFunction.java:46)  
               at  org.apache.sqoop.client.shell.ShowCommand (ShowCommand.java:82)  
               at  org.apache.sqoop.client.shell.SqoopCommand (SqoopCommand.java:127)  
      

        Attachments

        1. bugSQOOP-1040.patch
          0.8 kB
          Jarek Jarcec Cecho

          Issue Links

            Activity

              People

              • Assignee:
                jarcec Jarek Jarcec Cecho
                Reporter:
                jarcec Jarek Jarcec Cecho
              • Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: