Sqoop
  1. Sqoop
  2. SQOOP-1026

Sqoop2: Investigate recent maven failures

    Details

    • Type: Task Task
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: no-release
    • Component/s: None
    • Labels:
      None

      Description

      Our current builds are failing on generating documentation (hadoop100, hadoop200) generation. The maven output seems to be weird so I'm wondering if by any chance old version of maven is picked up.

        Activity

        Hide
        Jarek Jarcec Cecho added a comment -

        The last build for Hadoop 1.x has succeeded, so I'm resolving this JIRA.

        Show
        Jarek Jarcec Cecho added a comment - The last build for Hadoop 1.x has succeeded, so I'm resolving this JIRA.
        Hide
        Jarek Jarcec Cecho added a comment -

        The build for Hadoop 2.x was successfull. The build for Hadoop 1.x has failed on the known issue with return code 143, will rerun the build once again.

        Show
        Jarek Jarcec Cecho added a comment - The build for Hadoop 2.x was successfull . The build for Hadoop 1.x has failed on the known issue with return code 143, will rerun the build once again.
        Hide
        Jarek Jarcec Cecho added a comment -

        I've changed the build configuration from "Maven (latest)" to "Maven 3 (latest)". I'll kick off the build to see if it will help.

        Show
        Jarek Jarcec Cecho added a comment - I've changed the build configuration from "Maven (latest)" to "Maven 3 (latest)". I'll kick off the build to see if it will help.
        Hide
        Jarek Jarcec Cecho added a comment -

        I can confirm that the problem is in maven version. The build servers has started using version 2.2, however Sqoop requires at least version 3. I'll try to find out how to choose the proper version.

        Show
        Jarek Jarcec Cecho added a comment - I can confirm that the problem is in maven version. The build servers has started using version 2.2, however Sqoop requires at least version 3. I'll try to find out how to choose the proper version.

          People

          • Assignee:
            Jarek Jarcec Cecho
            Reporter:
            Jarek Jarcec Cecho
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development