Uploaded image for project: 'Spark'
  1. Spark
  2. SPARK-8781

Published POMs are no longer effective POMs

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Blocker
    • Resolution: Fixed
    • Affects Version/s: 1.3.2, 1.4.0, 1.5.0
    • Fix Version/s: 1.3.2, 1.4.1, 1.5.0
    • Component/s: Build
    • Labels:
      None

      Description

      Published to maven repository POMs are no longer effective POMs. E.g.

      In https://repository.apache.org/content/repositories/snapshots/org/apache/spark/spark-core_2.11/1.4.2-SNAPSHOT/spark-core_2.11-1.4.2-20150702.043114-52.pom:

      ...
      <dependency>
      <groupId>org.apache.spark</groupId>
      <artifactId>spark-launcher_${scala.binary.version}</artifactId>
      <version>${project.version}</version>
      </dependency>
      ...
      

      while it should be

      ...
      <dependency>
      <groupId>org.apache.spark</groupId>
      <artifactId>spark-launcher_2.11</artifactId>
      <version>${project.version}</version>
      </dependency>
      ...
      

      The following commits are most likely the cause of it:

      On branch-1.4 reverting the commit fixed the issue.

      See SPARK-3812 for additional details

        Attachments

          Activity

            People

            • Assignee:
              andrewor14 Andrew Or
              Reporter:
              k.shaposhnikov@gmail.com Konstantin Shaposhnikov
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: