Uploaded image for project: 'Spark'
  1. Spark
  2. SPARK-8015

flume-sink should not depend on Guava.

Attach filesAttach ScreenshotVotersWatch issueWatchersCreate sub-taskLinkCloneUpdate Comment AuthorReplace String in CommentUpdate Comment VisibilityDelete Comments
    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 1.4.0
    • Fix Version/s: 1.4.0
    • Component/s: DStreams
    • Labels:
      None

      Description

      The flume-sink module, due to the shared shading code in our build, ends up depending on the org.spark-project Guava classes. That means users who deploy the sink in Flume will also need to provide those classes somehow, generally by also adding the Spark assembly, which means adding a whole bunch of other libraries to Flume, which may or may not cause other unforeseen problems.

      It's better to not have that dependency in the flume-sink module instead.

        Attachments

          Activity

            People

            • Assignee:
              vanzin Marcelo Masiero Vanzin
              Reporter:
              vanzin Marcelo Masiero Vanzin

              Dates

              • Created:
                Updated:
                Resolved:

                Issue deployment