Uploaded image for project: 'Spark'
  1. Spark
  2. SPARK-36040

Add reference to kubernetes-client's version

    XMLWordPrintableJSON

    Details

    • Type: Documentation
    • Status: Resolved
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 3.1.2
    • Fix Version/s: 3.2.0, 3.1.3
    • Component/s: Documentation
    • Labels:
      None

      Description

      Running Spark on Kubernetes potentially has upper limitation of Kubernetes version.

      Compatibility Matrix

      e.g. Spark 3.1.2 uses kubernetes-client 4.12.0 and that does not support Kubernetes >= 1.19.1

      I think it is better for users to notice it because Kubernetes update speed is so fast that users tends to run Spark Jobs on unsupported version.

        Attachments

          Activity

            People

            • Assignee:
              yoda-mon Leona Yoda
              Reporter:
              yoda-mon Leona Yoda
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: