Uploaded image for project: 'Spark'
  1. Spark
  2. SPARK-25075 Build and test Spark against Scala 2.13
  3. SPARK-32398

Upgrade to scalatest 3.2.0 for Scala 2.13.3 compatibility

    XMLWordPrintableJSON

    Details

    • Target Version/s:

      Description

      We'll need to update to scalatest 3.2.0 in order to pick up the fix here, which fixes an incompatibility with Scala 2.13.3:

      https://github.com/scalatest/scalatest/commit/7c89416aa9f3e7f2730a343ad6d3bdcff65809de

      That's a big change unfortunately - 3.1 / 3.2 reorganized many classes. Fortunately it's just like import updates in 100 files.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                srowen Sean R. Owen
                Reporter:
                srowen Sean R. Owen
              • Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: