Uploaded image for project: 'Spark'
  1. Spark
  2. SPARK-27884 Deprecate Python 2 and Python 3 prior to 3.6 support in Spark 3.0
  3. SPARK-27887

Check python version and print deprecation warning if version < 3

    XMLWordPrintableJSON

    Details

    • Type: Sub-task
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 3.0.0
    • Fix Version/s: 3.0.0
    • Component/s: PySpark
    • Labels:
      None
    • Target Version/s:

      Description

      In Spark 3.0, users should see a deprecation warning if they use PySpark with Python < 3.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                mengxr Xiangrui Meng
                Reporter:
                mengxr Xiangrui Meng
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: