Uploaded image for project: 'Spark'
  1. Spark
  2. SPARK-27848

AppVeyor change to latest R version (3.6.0)

    XMLWordPrintableJSON

    Details

    • Type: Test
    • Status: Closed
    • Priority: Minor
    • Resolution: Duplicate
    • Affects Version/s: 3.0.0
    • Fix Version/s: 3.0.0
    • Component/s: SparkR
    • Labels:
      None

      Description

      R 3.6.0 is released last month. We better test higher versions of R in AppVeyor.

      We should set `R_REMOTES_NO_ERRORS_FROM_WARNINGS` to `true` to avoid the warnings below:

      Error in strptime(xx, f, tz = tz) : 
        (converted from warning) unable to identify current timezone 'C':
      please set environment variable 'TZ'
      Error in i.p(...) : 
        (converted from warning) installation of package 'praise' had non-zero exit status
      Calls: <Anonymous> ... with_rprofile_user -> with_envvar -> force -> force -> i.p
      Execution halted
      

      This JIRA targets to the latest of R version 3.6.0.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                Unassigned
                Reporter:
                hyukjin.kwon Hyukjin Kwon
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: