Uploaded image for project: 'Spark'
  1. Spark
  2. SPARK-17379

Upgrade netty-all to 4.0.41.Final (4.1.5-Final not compatible)

    Details

    • Type: Improvement
    • Status: Resolved
    • Priority: Trivial
    • Resolution: Fixed
    • Affects Version/s: 1.6.2, 2.0.0
    • Fix Version/s: 2.1.0
    • Component/s: Build
    • Labels:
      None

      Description

      We should use the newest version of netty based on info here: http://netty.io/news/2016/08/29/4-0-41-Final-4-1-5-Final.html, especially interested in the static initialiser deadlock fix: https://github.com/netty/netty/pull/5730

      Lots more fixes mentioned so will create the pull request - again a case of updating the pom and then the dependency files

        Attachments

          Activity

            People

            • Assignee:
              aroberts Adam Roberts
              Reporter:
              aroberts Adam Roberts
            • Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: