Uploaded image for project: 'Spark'
  1. Spark
  2. SPARK-15799 Release SparkR on CRAN
  3. SPARK-16509

Rename window.partitionBy and window.orderBy

Attach filesAttach ScreenshotVotersWatch issueWatchersLinkCloneUpdate Comment AuthorReplace String in CommentUpdate Comment VisibilityDelete Comments
    XMLWordPrintableJSON

    Details

    • Type: Sub-task
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 2.0.0
    • Component/s: SparkR
    • Labels:
      None

      Description

      Right now R CMD check [1] interprets window.partitonBy and window.orderBy as S3 functions defined on the "partitionBy" class or "orderBy" class (similar to say summary.lm)

      To avoid confusion I think we should just rename the functions and not use `.` in them ?

      cc Sun Rui

      [1] https://gist.github.com/shivaram/62866c4ca59c5d34b8963939cf04b5eb

        Attachments

          Activity

            People

            • Assignee:
              sunrui Sun Rui
              Reporter:
              shivaram Shivaram Venkataraman

              Dates

              • Created:
                Updated:
                Resolved:

                Issue deployment