Uploaded image for project: 'Spark'
  1. Spark
  2. SPARK-15761

pyspark shell should load if PYSPARK_DRIVER_PYTHON is ipython an Python3

    XMLWordPrintableJSON

    Details

    • Type: Improvement
    • Status: Resolved
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 1.6.3, 2.0.0
    • Component/s: PySpark
    • Labels:
      None

      Description

      My default python is ipython3 and it is odd that it fails with "IPython requires Python 2.7+; please install python2.7 or set PYSPARK_PYTHON"

        Attachments

          Activity

            People

            • Assignee:
              MechCoder Manoj Kumar
              Reporter:
              MechCoder Manoj Kumar
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: