Uploaded image for project: 'Solr'
  1. Solr
  2. SOLR-9944

Map the nodes function name to the GatherNodesStream

    Details

    • Type: Improvement
    • Status: Resolved
    • Priority: Major
    • Resolution: Resolved
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: None
    • Security Level: Public (Default Security Level. Issues are Public)
    • Labels:
      None

      Description

      This ticket maps the nodes function name to the GatherNodesStream. The gatherNodes function name will also remain mapped.

      I think nodes is just a better name for this function. Gather was meant to signify a breadth first traversal, but I think the docs can make this clear.

      I'll update the docs as well and mention that both function names work, but in the future gatherNodes may be phased out.

        Attachments

        1. SOLR-9944.patch
          3 kB
          Joel Bernstein

          Activity

            People

            • Assignee:
              Unassigned
              Reporter:
              joel.bernstein Joel Bernstein
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: