Details

    • Type: Sub-task
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 6.4, 7.0
    • Component/s: SolrJ
    • Labels:
      None

      Description

      CloudSolrClient should decouple itself from the ZK reading/write. This will help us provide alternate implementations w/o direct ZK dependency

        Issue Links

          Activity

          noble.paul Noble Paul added a comment -

          This refactoring also includes changes for SOLR-9512

          romseygeek Alan Woodward added a comment -

          Can we make ClusterStateProvider a top-level interface, and make ZkStateReader implement it directly?

          noble.paul Noble Paul added a comment - - edited

          sounds good , lemme try

          Actually, no. The ClusterStateProvider is lazily connected only after the connect() call. Whereas we expect the ZkStateReader to be connected immediately

          jira-bot ASF subversion and git services added a comment -

          Commit e309f9058985375076cac0ed982a158dd865b86a in lucene-solr's branch refs/heads/branch_6x from Noble Paul
          [ https://git-wip-us.apache.org/repos/asf?p=lucene-solr.git;h=e309f90 ]

          SOLR-9784: Refactor CloudSolrClient to eliminate direct dependency on ZK
          SOLR-9512: CloudSolrClient's cluster state cache can break direct updates to leaders

          jira-bot ASF subversion and git services added a comment -

          Commit d87ffa4bf82c30e9a6f0bbb6b8c0087a5c07f9d6 in lucene-solr's branch refs/heads/master from Noble Paul
          [ https://git-wip-us.apache.org/repos/asf?p=lucene-solr.git;h=d87ffa4 ]

          SOLR-9784: Refactor CloudSolrClient to eliminate direct dependency on ZK
          SOLR-9512: CloudSolrClient's cluster state cache can break direct updates to leaders

          jira-bot ASF subversion and git services added a comment -

          Commit 5650939a8d41b7bad584947a2c9dcedf3774b8de in lucene-solr's branch refs/heads/master from Noble Paul
          [ https://git-wip-us.apache.org/repos/asf?p=lucene-solr.git;h=5650939 ]

          SOLR-9784: Refactor CloudSolrClient to eliminate direct dependency on ZK
          SOLR-9512: CloudSolrClient's cluster state cache can break direct updates to leaders

          jira-bot ASF subversion and git services added a comment -

          Commit 8201ddc3b39adaad18ba0fc369d5383dbdb8926e in lucene-solr's branch refs/heads/branch_6x from Noble Paul
          [ https://git-wip-us.apache.org/repos/asf?p=lucene-solr.git;h=8201ddc ]

          SOLR-9784: Refactor CloudSolrClient to eliminate direct dependency on ZK

          shalinmangar Shalin Shekhar Mangar added a comment -

          The ZkClientClusterStateProvider.buildZkHostString method is a duplicate of CloudSolrClient.buildZkHostString – can we re-use the same method in both places?

          noble.paul Noble Paul added a comment -

          Will do

          jira-bot ASF subversion and git services added a comment -

          Commit dce5964d8a19c288b34b7671bcfeb2844d83d882 in lucene-solr's branch refs/heads/master from Noble Paul
          [ https://git-wip-us.apache.org/repos/asf?p=lucene-solr.git;h=dce5964 ]

          SOLR-9784: removed unused method

          jira-bot ASF subversion and git services added a comment -

          Commit 579813ef13a67f75af6e64374e6ec219727f41fd in lucene-solr's branch refs/heads/branch_6x from Noble Paul
          [ https://git-wip-us.apache.org/repos/asf?p=lucene-solr.git;h=579813e ]

          SOLR-9784: removed unused method

          jira-bot ASF subversion and git services added a comment -

          Commit 00dfbafd9aaec2ac73e812635bad23047d4f2be1 in lucene-solr's branch refs/heads/branch_6x from Noble Paul
          [ https://git-wip-us.apache.org/repos/asf?p=lucene-solr.git;h=00dfbaf ]

          SOLR-9784: deprecated uploadconfig

          jira-bot ASF subversion and git services added a comment -

          Commit 2ec97165204a9e4b55419816fc10eaaab6c9095f in lucene-solr's branch refs/heads/master from Noble Paul
          [ https://git-wip-us.apache.org/repos/asf?p=lucene-solr.git;h=2ec9716 ]

          SOLR-9784: deprecated uploadconfig

          jira-bot ASF subversion and git services added a comment -

          Commit 23921064e963d7f1f91594725b88f6838a263fae in lucene-solr's branch refs/heads/master from Noble Paul
          [ https://git-wip-us.apache.org/repos/asf?p=lucene-solr.git;h=2392106 ]

          SOLR-9784: deprecated uploadconfig

          jira-bot ASF subversion and git services added a comment -

          Commit 5b2594350df11ef54d52f417b34c6d082ad85e89 in lucene-solr's branch refs/heads/master from Noble Paul
          [ https://git-wip-us.apache.org/repos/asf?p=lucene-solr.git;h=5b25943 ]

          SOLR-9784: added deprecation javadocs

          jira-bot ASF subversion and git services added a comment -

          Commit d89da61a6dfed2cec5b2232ae978ebd71f1216de in lucene-solr's branch refs/heads/branch_6x from Noble Paul
          [ https://git-wip-us.apache.org/repos/asf?p=lucene-solr.git;h=d89da61 ]

          SOLR-9784: added deprecation javadocs

          jira-bot ASF subversion and git services added a comment -

          Commit 5b2594350df11ef54d52f417b34c6d082ad85e89 in lucene-solr's branch refs/heads/feature/metrics from Noble Paul
          [ https://git-wip-us.apache.org/repos/asf?p=lucene-solr.git;h=5b25943 ]

          SOLR-9784: added deprecation javadocs


            People

            • Assignee:
              noble.paul Noble Paul
              Reporter:
              noble.paul Noble Paul
            • Votes:
              0 Vote for this issue
              Watchers:
              5 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development