Solr
  1. Solr
  2. SOLR-975

admin-extra.html not currectly display when using multicore configuration

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 1.4
    • Fix Version/s: 4.0-ALPHA
    • Component/s: web gui
    • Labels:
      None
    • Environment:

      Jetty openjdk 1.6.0 1.0.b12 (EPEL package for EL5)

      Description

      I'm having "cross-talk" issues with using the Solr nightlies (and probably w/ 1.3.0 release but have not tested as I needed newer features of the DataImportHandler in the nightlies)

      Basic scenario for this bug is as follows

      I have two cores configured and BOTH have a customized "admin-extra.html", however going to the admin pages uses the SAME admin-extra.html for all cores. the one used is whichever core is browsed first.. This looks like a caching bug where the cache is not taking into account the Core.

      Basically my admin-extra.html has a link to the data importer script and a link to reload the core (which has to have the core name explicitly in the per-core admin-extra.html).

        Issue Links

          Activity

          Hoss Man added a comment -

          Thanks for verifying Edward

          Edward Rudd added a comment -

          I have confirmed this issue is fixed in the 4.0 nightly build from today.

          Edward Rudd added a comment -

          From looking at the diff it looks like it could fix it.. But it needs to be verified that it is indeed fixed. I'll at to my TODO list to pull down a nightly build next week and test.

          Hoss Man added a comment -

          FYI: i'm pretty sure yonik fixed this as part of SOLR-1930, but i haven't tested...

          http://svn.apache.org/viewvc?view=revision&revision=1054008

          Edward Rudd added a comment -

          I agree that a real more robust system should be built.. Abusing the tables with badly formatted HTML to do what is currently being done is HORRID.

          Any suggestions on a "cleaner" way of doing this? and which source files do I need to tear apart? (I'll work on a patch)

          Hoss Man added a comment -

          support for admin-extras.html has always been a hack ... the implementation only ever worked for single core setups because it depended on functionality that took advantage of the singleton.

          a fix should be possible, but it might make more sense to just scrap the idea of a magicly named HTML snippet file that is included verbatim (in the middle of an open table tag no less) and come up with a more intuitive and robust way to let people configure what should appear on the admin screen


            People

            • Assignee:
              Yonik Seeley
              Reporter:
              Edward Rudd
            • Votes:
              1 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development