Uploaded image for project: 'Solr'
  1. Solr
  2. SOLR-9459

Upgrade dependencies

    XMLWordPrintableJSON

    Details

    • Type: Improvement
    • Status: Open
    • Priority: Major
    • Resolution: Unresolved
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None

      Description

      Hello,

      my project has more than 400 dependencies and I'm trying to ban the usage of commons-collecrtions and commons-lang in favor of org.apache.commons:commons-collection4 and org.apache.commons:commons-lang3. Unfortunately out of the 400 dependencies only solr is still using the old collections and lang dependencies which are more than 6 years old.

      Is there a specific reason for that? Can you please update to the latest versions:

      http://repo1.maven.org/maven2/org/apache/commons/commons-lang3/
      http://repo1.maven.org/maven2/org/apache/commons/commons-collections4/
      http://repo1.maven.org/maven2/org/apache/commons/commons-configuration2/
      http://repo1.maven.org/maven2/org/apache/commons/commons-io/

        Attachments

        1. commons-lang3.patch
          38 kB
          Jan H√łydahl

          Issue Links

            Activity

              People

              • Assignee:
                Unassigned
                Reporter:
                paranoiabla Petar Tahchiev
              • Votes:
                0 Vote for this issue
                Watchers:
                7 Start watching this issue

                Dates

                • Created:
                  Updated: