Noble Paul can you add a package for all these classes? It would help organize the code around here better. Perhaps Overseer*.java should go there too (+ classes only used by them, like...?) and we call this package "overseer"? If that's too much then maybe just call the package "overseer-cmd".