I'm always in favor of returning more data to the user. I do have one question though in terms of existing installations. An installation that looked at "errors" will now see that value drop by "clientErrors".
Personally I think this is OK, it's easier to explain than "we didn't change 'errors' because...."
Hmmm, What do you (or others) think about returning "errors" as the sum of client errors and server errors like now, but returning two new bits like this?
lst.add("errors", numServerErrors.longValue() + numClientErrors.longValue());
That would leave existing behavior intact but provide the additional info.
I'm not so much recommending that as throwing it out there for discussion.
+1 generally though.