Uploaded image for project: 'Solr'
  1. Solr
  2. SOLR-9005

In files example, update-script.js scripting URP fails with method signature mismatch

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 6.0
    • Fix Version/s: 6.4, 7.0
    • Component/s: examples
    • Labels:
      None
    • Environment:

      Mac
      java version "1.8.0_31"

      Description

      Following the files example README:
      bin/solr start
      bin/solr create -c files -d example/files/conf
      bin/post -c files docs/solr-analytics/index.html # (just one reproducible example)

      Unable to invoke function processAdd in script: update-script.js: Can't unambiguously select between fixed arity signatures [(java.lang.String, java.io.Reader), (java.lang.String, java.lang.String)] of the method org.apache.solr.analysis.TokenizerChain.tokenStream for argument types [java.lang.String, null]
      
      1. SOLR-9005.patch
        1.0 kB
        Alexandre Rafalovitch

        Activity

        arafalov Alexandre Rafalovitch added a comment -

        Full exception stack trace:

        $ bin/post -c files docs/solr-analytics/index.html
        java -classpath /Users/arafalov/SearchEngines/solr-6.0.0/dist/solr-core-6.0.0.jar -Dauto=yes -Dc=files -Ddata=files org.apache.solr.util.SimplePostTool docs/solr-analytics/index.html
        SimplePostTool version 5.0.0
        Posting files to [base] url http://localhost:8983/solr/files/update...
        Entering auto mode. File endings considered are xml,json,jsonl,csv,pdf,doc,docx,ppt,pptx,xls,xlsx,odt,odp,ods,ott,otp,ots,rtf,htm,html,txt,log
        POSTing file index.html (text/html) to [base]/extract
        SimplePostTool: WARNING: Solr returned an error #500 (Server Error) for url: http://localhost:8983/solr/files/update/extract?resource.name=%2FUsers%2Farafalov%2FSearchEngines%2Fsolr-6.0.0%2Fdocs%2Fsolr-analytics%2Findex.html&literal.id=%2FUsers%2Farafalov%2FSearchEngines%2Fsolr-6.0.0%2Fdocs%2Fsolr-analytics%2Findex.html
        SimplePostTool: WARNING: Response: <?xml version="1.0" encoding="UTF-8"?>
        <response>
        <lst name="responseHeader"><int name="status">500</int><int name="QTime">704</int></lst><lst name="error"><lst name="metadata"><str name="error-class">org.apache.solr.common.SolrException</str><str name="root-error-class">java.lang.NoSuchMethodException</str></lst><str name="msg">Unable to invoke function processAdd in script: update-script.js: Can't unambiguously select between fixed arity signatures [(java.lang.String, java.io.Reader), (java.lang.String, java.lang.String)] of the method org.apache.solr.analysis.TokenizerChain.tokenStream for argument types [java.lang.String, null]</str><str name="trace">org.apache.solr.common.SolrException: Unable to invoke function processAdd in script: update-script.js: Can't unambiguously select between fixed arity signatures [(java.lang.String, java.io.Reader), (java.lang.String, java.lang.String)] of the method org.apache.solr.analysis.TokenizerChain.tokenStream for argument types [java.lang.String, null]
        	at org.apache.solr.update.processor.StatelessScriptUpdateProcessorFactory$ScriptUpdateProcessor.invokeFunction(StatelessScriptUpdateProcessorFactory.java:436)
        	at org.apache.solr.update.processor.StatelessScriptUpdateProcessorFactory$ScriptUpdateProcessor.processAdd(StatelessScriptUpdateProcessorFactory.java:373)
        	at org.apache.solr.update.processor.UpdateRequestProcessor.processAdd(UpdateRequestProcessor.java:48)
        	at org.apache.solr.update.processor.LanguageIdentifierUpdateProcessor.processAdd(LanguageIdentifierUpdateProcessor.java:206)
        	at org.apache.solr.update.processor.UpdateRequestProcessor.processAdd(UpdateRequestProcessor.java:48)
        	at org.apache.solr.update.processor.AddSchemaFieldsUpdateProcessorFactory$AddSchemaFieldsUpdateProcessor.processAdd(AddSchemaFieldsUpdateProcessorFactory.java:335)
        	at org.apache.solr.update.processor.UpdateRequestProcessor.processAdd(UpdateRequestProcessor.java:48)
        	at org.apache.solr.update.processor.FieldMutatingUpdateProcessor.processAdd(FieldMutatingUpdateProcessor.java:117)
        	at org.apache.solr.update.processor.UpdateRequestProcessor.processAdd(UpdateRequestProcessor.java:48)
        	at org.apache.solr.update.processor.FieldMutatingUpdateProcessor.processAdd(FieldMutatingUpdateProcessor.java:117)
        	at org.apache.solr.update.processor.UpdateRequestProcessor.processAdd(UpdateRequestProcessor.java:48)
        	at org.apache.solr.update.processor.FieldMutatingUpdateProcessor.processAdd(FieldMutatingUpdateProcessor.java:117)
        	at org.apache.solr.update.processor.UpdateRequestProcessor.processAdd(UpdateRequestProcessor.java:48)
        	at org.apache.solr.update.processor.FieldMutatingUpdateProcessor.processAdd(FieldMutatingUpdateProcessor.java:117)
        	at org.apache.solr.update.processor.UpdateRequestProcessor.processAdd(UpdateRequestProcessor.java:48)
        	at org.apache.solr.update.processor.FieldNameMutatingUpdateProcessorFactory$1.processAdd(FieldNameMutatingUpdateProcessorFactory.java:74)
        	at org.apache.solr.update.processor.UpdateRequestProcessor.processAdd(UpdateRequestProcessor.java:48)
        	at org.apache.solr.update.processor.FieldMutatingUpdateProcessor.processAdd(FieldMutatingUpdateProcessor.java:117)
        	at org.apache.solr.update.processor.UpdateRequestProcessor.processAdd(UpdateRequestProcessor.java:48)
        	at org.apache.solr.update.processor.DistributedUpdateProcessor.doLocalAdd(DistributedUpdateProcessor.java:936)
        	at org.apache.solr.update.processor.DistributedUpdateProcessor.versionAdd(DistributedUpdateProcessor.java:1091)
        	at org.apache.solr.update.processor.DistributedUpdateProcessor.processAdd(DistributedUpdateProcessor.java:714)
        	at org.apache.solr.update.processor.LogUpdateProcessorFactory$LogUpdateProcessor.processAdd(LogUpdateProcessorFactory.java:103)
        	at org.apache.solr.update.processor.UpdateRequestProcessor.processAdd(UpdateRequestProcessor.java:48)
        	at org.apache.solr.update.processor.AbstractDefaultValueUpdateProcessorFactory$DefaultValueUpdateProcessor.processAdd(AbstractDefaultValueUpdateProcessorFactory.java:93)
        	at org.apache.solr.handler.extraction.ExtractingDocumentLoader.doAdd(ExtractingDocumentLoader.java:126)
        	at org.apache.solr.handler.extraction.ExtractingDocumentLoader.addDoc(ExtractingDocumentLoader.java:131)
        	at org.apache.solr.handler.extraction.ExtractingDocumentLoader.load(ExtractingDocumentLoader.java:237)
        	at org.apache.solr.handler.ContentStreamHandlerBase.handleRequestBody(ContentStreamHandlerBase.java:69)
        	at org.apache.solr.handler.RequestHandlerBase.handleRequest(RequestHandlerBase.java:155)
        	at org.apache.solr.core.SolrCore.execute(SolrCore.java:2033)
        	at org.apache.solr.servlet.HttpSolrCall.execute(HttpSolrCall.java:652)
        	at org.apache.solr.servlet.HttpSolrCall.call(HttpSolrCall.java:460)
        	at org.apache.solr.servlet.SolrDispatchFilter.doFilter(SolrDispatchFilter.java:229)
        	at org.apache.solr.servlet.SolrDispatchFilter.doFilter(SolrDispatchFilter.java:184)
        	at org.eclipse.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1668)
        	at org.eclipse.jetty.servlet.ServletHandler.doHandle(ServletHandler.java:581)
        	at org.eclipse.jetty.server.handler.ScopedHandler.handle(ScopedHandler.java:143)
        	at org.eclipse.jetty.security.SecurityHandler.handle(SecurityHandler.java:548)
        	at org.eclipse.jetty.server.session.SessionHandler.doHandle(SessionHandler.java:226)
        	at org.eclipse.jetty.server.handler.ContextHandler.doHandle(ContextHandler.java:1160)
        	at org.eclipse.jetty.servlet.ServletHandler.doScope(ServletHandler.java:511)
        	at org.eclipse.jetty.server.session.SessionHandler.doScope(SessionHandler.java:185)
        	at org.eclipse.jetty.server.handler.ContextHandler.doScope(ContextHandler.java:1092)
        	at org.eclipse.jetty.server.handler.ScopedHandler.handle(ScopedHandler.java:141)
        	at org.eclipse.jetty.server.handler.ContextHandlerCollection.handle(ContextHandlerCollection.java:213)
        	at org.eclipse.jetty.server.handler.HandlerCollection.handle(HandlerCollection.java:119)
        	at org.eclipse.jetty.server.handler.HandlerWrapper.handle(HandlerWrapper.java:134)
        	at org.eclipse.jetty.server.Server.handle(Server.java:518)
        	at org.eclipse.jetty.server.HttpChannel.handle(HttpChannel.java:308)
        	at org.eclipse.jetty.server.HttpConnection.onFillable(HttpConnection.java:244)
        	at org.eclipse.jetty.io.AbstractConnection$ReadCallback.succeeded(AbstractConnection.java:273)
        	at org.eclipse.jetty.io.FillInterest.fillable(FillInterest.java:95)
        	at org.eclipse.jetty.io.SelectChannelEndPoint$2.run(SelectChannelEndPoint.java:93)
        	at org.eclipse.jetty.util.thread.strategy.ExecuteProduceConsume.produceAndRun(ExecuteProduceConsume.java:246)
        	at org.eclipse.jetty.util.thread.strategy.ExecuteProduceConsume.run(ExecuteProduceConsume.java:156)
        	at org.eclipse.jetty.util.thread.QueuedThreadPool.runJob(QueuedThreadPool.java:654)
        	at org.eclipse.jetty.util.thread.QueuedThreadPool$3.run(QueuedThreadPool.java:572)
        	at java.lang.Thread.run(Thread.java:745)
        Caused by: java.lang.NoSuchMethodException: Can't unambiguously select between fixed arity signatures [(java.lang.String, java.io.Reader), (java.lang.String, java.lang.String)] of the method org.apache.solr.analysis.TokenizerChain.tokenStream for argument types [java.lang.String, null]
        	at jdk.internal.dynalink.beans.OverloadedMethod.throwAmbiguousMethod(OverloadedMethod.java:222)
        	at jdk.nashorn.internal.scripts.Script$\^eval\_.processAdd(&lt;eval&gt;:81)
        	at jdk.nashorn.internal.runtime.ScriptFunctionData.invoke(ScriptFunctionData.java:537)
        	at jdk.nashorn.internal.runtime.ScriptFunction.invoke(ScriptFunction.java:209)
        	at jdk.nashorn.internal.runtime.ScriptRuntime.apply(ScriptRuntime.java:378)
        	at jdk.nashorn.api.scripting.ScriptObjectMirror.callMember(ScriptObjectMirror.java:185)
        	at jdk.nashorn.api.scripting.NashornScriptEngine.invokeImpl(NashornScriptEngine.java:505)
        	at jdk.nashorn.api.scripting.NashornScriptEngine.invokeFunction(NashornScriptEngine.java:227)
        	at org.apache.solr.update.processor.StatelessScriptUpdateProcessorFactory$ScriptUpdateProcessor.invokeFunction(StatelessScriptUpdateProcessorFactory.java:424)
        	... 58 more
        </str><int name="code">500</int></lst>
        </response>
        SimplePostTool: WARNING: IOException while reading response: java.io.IOException: Server returned HTTP response code: 500 for URL: http://localhost:8983/solr/files/update/extract?resource.name=%2FUsers%2Farafalov%2FSearchEngines%2Fsolr-6.0.0%2Fdocs%2Fsolr-analytics%2Findex.html&literal.id=%2FUsers%2Farafalov%2FSearchEngines%2Fsolr-6.0.0%2Fdocs%2Fsolr-analytics%2Findex.html
        1 files indexed.
        COMMITting Solr index changes to http://localhost:8983/solr/files/update...
        Time spent: 0:00:00.742
        
        arafalov Alexandre Rafalovitch added a comment -

        Added a guard condition for when content stream is empty.

        jira-bot ASF subversion and git services added a comment -

        Commit 9148362617333458e22d7d3c28b26053f4308fa6 in lucene-solr's branch refs/heads/master from Alexandre Rafalovitch
        [ https://git-wip-us.apache.org/repos/asf?p=lucene-solr.git;h=9148362 ]

        SOLR-9005: Add guard condition to the example js

        jira-bot ASF subversion and git services added a comment -

        Commit dc485a0eb6ad531f01b8cb64a30b4c60eeef7ecb in lucene-solr's branch refs/heads/branch_6x from Alexandre Rafalovitch
        [ https://git-wip-us.apache.org/repos/asf?p=lucene-solr.git;h=dc485a0 ]

        SOLR-9005: Add guard condition to the example js

        arafalov Alexandre Rafalovitch added a comment -

        The patch from April applied cleanly

        jira-bot ASF subversion and git services added a comment -

        Commit d06605191a00d8db3e8f760c620084de1f234e96 in lucene-solr's branch refs/heads/branch_6x from Adrien Grand
        [ https://git-wip-us.apache.org/repos/asf?p=lucene-solr.git;h=d066051 ]

        SOLR-9005: Remove tabs from solr/example/files/conf/update-script.js.

        jira-bot ASF subversion and git services added a comment -

        Commit 284eb77ece6e313f1d309246b48ecdde23228926 in lucene-solr's branch refs/heads/master from Adrien Grand
        [ https://git-wip-us.apache.org/repos/asf?p=lucene-solr.git;h=284eb77 ]

        SOLR-9005: Remove tabs from solr/example/files/conf/update-script.js.

        jira-bot ASF subversion and git services added a comment -

        Commit 9148362617333458e22d7d3c28b26053f4308fa6 in lucene-solr's branch refs/heads/apiv2 from Alexandre Rafalovitch
        [ https://git-wip-us.apache.org/repos/asf?p=lucene-solr.git;h=9148362 ]

        SOLR-9005: Add guard condition to the example js

        jira-bot ASF subversion and git services added a comment -

        Commit 284eb77ece6e313f1d309246b48ecdde23228926 in lucene-solr's branch refs/heads/apiv2 from Adrien Grand
        [ https://git-wip-us.apache.org/repos/asf?p=lucene-solr.git;h=284eb77 ]

        SOLR-9005: Remove tabs from solr/example/files/conf/update-script.js.


          People

          • Assignee:
            arafalov Alexandre Rafalovitch
            Reporter:
            arafalov Alexandre Rafalovitch
          • Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development