Uploaded image for project: 'Solr'
  1. Solr
  2. SOLR-8961

TestMiniSolrCloudCluster should move into test-framework

    Details

    • Type: Test
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 6.3
    • Component/s: None
    • Labels:
      None

      Description

      • MiniSolrCloudCluster was designed to be a "cloud helper class" for writting cloud based tests.
      • TestMiniSolrCloudCluster was designed to be a "test the cloud helper class" type of test, verifying that MiniSolrCloudCluster would behave the the documented/expected ways, so people could be confident in writting tests using it.

      But because TestMiniSolrCloudCluster currently lives in the solr-core test package, it's easy to confuse it for a "test solr using a cloud helper class" test, that people might try adding tests of core solr functionality to (see SOLR-8959)

      We should move this test so it's actaully part of the test-framework.

      1. SOLR-8961.patch
        11 kB
        Alan Woodward

        Issue Links

          Activity

          romseygeek Alan Woodward added a comment -

          Here's a patch that:
          a) creates a new solr-test-framework test module with ant, maven and intellij support
          b) moves some of the TestMiniSolrCloudCluster tests into that module

          I didn't move all the tests, mainly because they seem to be testing the collections API rather than the mini-cluster itself.

          shalinmangar Shalin Shekhar Mangar added a comment -

          creates a new solr-test-framework test module with ant, maven and intellij support

          This exists already. What am I missing?

          romseygeek Alan Woodward added a comment -

          The main module already exists, the tests module doesn't.

          shalinmangar Shalin Shekhar Mangar added a comment -

          Ah, okay, I missed that. Sorry for the noise.

          jira-bot ASF subversion and git services added a comment -

          Commit d8a2600cc690bf87b0b578d0e4f4c6e3a5e79db0 in lucene-solr's branch refs/heads/branch_6x from Alan Woodward
          [ https://git-wip-us.apache.org/repos/asf?p=lucene-solr.git;h=d8a2600 ]

          SOLR-8961: Add a test-the-tests module for solr-test-framework

          jira-bot ASF subversion and git services added a comment -

          Commit 6390e22e7446d33e9d996ee76330b4cc94f654a4 in lucene-solr's branch refs/heads/master from Alan Woodward
          [ https://git-wip-us.apache.org/repos/asf?p=lucene-solr.git;h=6390e22 ]

          SOLR-8961: Add a test-the-tests module for solr-test-framework

          shalinmangar Shalin Shekhar Mangar added a comment -

          Closing after 6.3.0 release.


            People

            • Assignee:
              romseygeek Alan Woodward
              Reporter:
              hossman Hoss Man
            • Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development