Details

    • Type: Sub-task
    • Status: Resolved
    • Priority: Major
    • Resolution: Implemented
    • Affects Version/s: 6.0
    • Fix Version/s: 6.0
    • Component/s: SolrJ
    • Labels:
      None

      Description

      DbVisualizer NPE when clicking on DB References tab. After connecting, NPE if double click on "DB" under connection name then click on References tab.

      1. SOLR-8819.patch
        15 kB
        Trey Cahill
      2. SOLR-8819.patch
        20 kB
        Trey Cahill
      3. SOLR-8819.patch
        18 kB
        Trey Cahill
      4. SOLR-8819.patch
        14 kB
        Kevin Risden
      5. SOLR-8819.patch
        13 kB
        Kevin Risden
      6. SOLR-8819.patch
        11 kB
        Kevin Risden
      7. SOLR-8819.patch
        7 kB
        Trey Cahill

        Issue Links

          Activity

          cahilltr Trey Cahill added a comment -

          Added a patch that fixes the NPE caused by clicking on the DB References tab by implementing the getTables() method in DatabaseMetaDataImpl. Removed restriction of requiring the field "TABLE_CAT" when querying CATALOGS by wrapping CatalogsStream in SelectStream. Removed restriction of requiring the both the fields "TABLE_SCHEM" and "TABLE_CATALOG" when querying SCHEMAS by wrapping SchemasStream in SelectStream. Added tests as needed.

          risdenk Kevin Risden added a comment -

          Since DatabaseMetaDataImpl.getTables isn't fully implemented, it looks like it causes the following errors in DbVisualizer when clicking on the table looking icon under the table name. We should probably implement all of the return columns for DatabaseMetaDataImpl.getTables instead of just the two currently in the patch.

          2016-03-11 08:24:34.821 FINE   870 [pool-3-thread-2 - E.ᅣチ] RootConnection: DatabaseMetaDataImpl.getTables("localhost:9983", "test", "%", null)
          2016-03-11 08:24:34.843 FINE   870 [ExecutorRunner-pool-2-thread-1 - E.ᅣツ] getting column 1 (java.lang.String) 'TABLE_SCHEM' using getString()
          2016-03-11 08:24:34.843 FINE   870 [ExecutorRunner-pool-2-thread-1 - E.ᅣツ] getting column 2 (java.lang.String) 'TABLE_CATALOG' using getString()
          2016-03-11 08:24:34.844 FINE   870 [ExecutorRunner-pool-2-thread-1 - Z.processResultSet] Fetched Rows: 1 Columns: 2 Exec: 0.022 Fetch: 0.000 sec
          2016-03-11 08:24:34.847 WARN   870 [ExecutorRunner-pool-2-thread-1 - C.getValueAt] IndexOutOfBoundsException: row=0 column=2 rowCount=1 columnCount=2
          java.lang.IndexOutOfBoundsException: Index: 2, Size: 2
          	at java.util.ArrayList.rangeCheck(ArrayList.java:653)
          	at java.util.ArrayList.get(ArrayList.java:429)
          	at com.onseven.dbvis.K.A.C.getValueAt(Z:2606)
          	at com.onseven.dbvis.K.B.B.ᅥネ(Z:61)
          	at com.onseven.dbvis.n.I.K.ᅣチ(Z:2413)
          	at com.onseven.dbvis.n.I.K.ᅣチ(Z:240)
          	at com.onseven.dbvis.n.I.K.ᅣチ(Z:2852)
          	at com.onseven.dbvis.n.I.K.execute(Z:659)
          	at com.onseven.dbvis.K.B.Z.ᅣチ(Z:2285)
          	at com.onseven.dbvis.K.B.L.ᅣツ(Z:1374)
          	at com.onseven.dbvis.K.B.L.doInBackground(Z:1521)
          	at javax.swing.SwingWorker$1.call(SwingWorker.java:295)
          	at java.util.concurrent.FutureTask.run(FutureTask.java:266)
          	at javax.swing.SwingWorker.run(SwingWorker.java:334)
          	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)
          	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)
          	at java.lang.Thread.run(Thread.java:745)
          2016-03-11 08:24:34.850 WARN   870 [ExecutorRunner-pool-2-thread-1 - C.getValueAt] IndexOutOfBoundsException: row=0 column=3 rowCount=1 columnCount=2
          java.lang.IndexOutOfBoundsException: Index: 3, Size: 2
          	at java.util.ArrayList.rangeCheck(ArrayList.java:653)
          	at java.util.ArrayList.get(ArrayList.java:429)
          	at com.onseven.dbvis.K.A.C.getValueAt(Z:2606)
          	at com.onseven.dbvis.K.B.B.ᅥネ(Z:61)
          	at com.onseven.dbvis.n.I.K.ᅣチ(Z:2413)
          	at com.onseven.dbvis.n.I.K.ᅣチ(Z:240)
          	at com.onseven.dbvis.n.I.K.ᅣチ(Z:2852)
          	at com.onseven.dbvis.n.I.K.execute(Z:659)
          	at com.onseven.dbvis.K.B.Z.ᅣチ(Z:2285)
          	at com.onseven.dbvis.K.B.L.ᅣツ(Z:1374)
          	at com.onseven.dbvis.K.B.L.doInBackground(Z:1521)
          	at javax.swing.SwingWorker$1.call(SwingWorker.java:295)
          	at java.util.concurrent.FutureTask.run(FutureTask.java:266)
          	at javax.swing.SwingWorker.run(SwingWorker.java:334)
          	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)
          	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)
          	at java.lang.Thread.run(Thread.java:745)
          2016-03-11 08:24:34.853 WARN   870 [ExecutorRunner-pool-2-thread-1 - C.getValueAt] IndexOutOfBoundsException: row=0 column=4 rowCount=1 columnCount=2
          java.lang.IndexOutOfBoundsException: Index: 4, Size: 2
          	at java.util.ArrayList.rangeCheck(ArrayList.java:653)
          	at java.util.ArrayList.get(ArrayList.java:429)
          	at com.onseven.dbvis.K.A.C.getValueAt(Z:2606)
          	at com.onseven.dbvis.K.B.B.ᅥネ(Z:61)
          	at com.onseven.dbvis.n.I.K.ᅣチ(Z:2413)
          	at com.onseven.dbvis.n.I.K.ᅣチ(Z:240)
          	at com.onseven.dbvis.n.I.K.ᅣチ(Z:2852)
          	at com.onseven.dbvis.n.I.K.execute(Z:659)
          	at com.onseven.dbvis.K.B.Z.ᅣチ(Z:2285)
          	at com.onseven.dbvis.K.B.L.ᅣツ(Z:1374)
          	at com.onseven.dbvis.K.B.L.doInBackground(Z:1521)
          	at javax.swing.SwingWorker$1.call(SwingWorker.java:295)
          	at java.util.concurrent.FutureTask.run(FutureTask.java:266)
          	at javax.swing.SwingWorker.run(SwingWorker.java:334)
          	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)
          	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)
          	at java.lang.Thread.run(Thread.java:745)
          2016-03-11 08:24:34.855 WARN   870 [ExecutorRunner-pool-2-thread-1 - C.getValueAt] IndexOutOfBoundsException: row=0 column=3 rowCount=1 columnCount=3
          java.lang.IndexOutOfBoundsException: Index: 3, Size: 3
          	at java.util.ArrayList.rangeCheck(ArrayList.java:653)
          	at java.util.ArrayList.get(ArrayList.java:429)
          	at com.onseven.dbvis.K.A.C.getValueAt(Z:2606)
          	at com.jidesoft.grid.TableModelWrapperImpl.getValueAt(Unknown Source)
          	at com.jidesoft.grid.DefaultTableModelWrapper.getValueAt(Unknown Source)
          	at com.onseven.dbvis.K.B._.ᅣチ(Z:292)
          	at com.onseven.dbvis.n.I.K.ᅣチ(Z:679)
          	at com.onseven.dbvis.n.I.K.ᅣチ(Z:240)
          	at com.onseven.dbvis.n.I.K.ᅣチ(Z:2852)
          	at com.onseven.dbvis.n.I.K.execute(Z:659)
          	at com.onseven.dbvis.K.B.Z.ᅣチ(Z:2285)
          	at com.onseven.dbvis.K.B.L.ᅣツ(Z:1374)
          	at com.onseven.dbvis.K.B.L.doInBackground(Z:1521)
          	at javax.swing.SwingWorker$1.call(SwingWorker.java:295)
          	at java.util.concurrent.FutureTask.run(FutureTask.java:266)
          	at javax.swing.SwingWorker.run(SwingWorker.java:334)
          	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)
          	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)
          	at java.lang.Thread.run(Thread.java:745)
          2016-03-11 08:24:34.856 WARN   870 [ExecutorRunner-pool-2-thread-1 - C.getValueAt] IndexOutOfBoundsException: row=0 column=4 rowCount=1 columnCount=3
          java.lang.IndexOutOfBoundsException: Index: 4, Size: 3
          	at java.util.ArrayList.rangeCheck(ArrayList.java:653)
          	at java.util.ArrayList.get(ArrayList.java:429)
          	at com.onseven.dbvis.K.A.C.getValueAt(Z:2606)
          	at com.jidesoft.grid.TableModelWrapperImpl.getValueAt(Unknown Source)
          	at com.jidesoft.grid.DefaultTableModelWrapper.getValueAt(Unknown Source)
          	at com.onseven.dbvis.K.B._.ᅣチ(Z:292)
          	at com.onseven.dbvis.n.I.K.ᅣチ(Z:679)
          	at com.onseven.dbvis.n.I.K.ᅣチ(Z:240)
          	at com.onseven.dbvis.n.I.K.ᅣチ(Z:2852)
          	at com.onseven.dbvis.n.I.K.execute(Z:659)
          	at com.onseven.dbvis.K.B.Z.ᅣチ(Z:2285)
          	at com.onseven.dbvis.K.B.L.ᅣツ(Z:1374)
          	at com.onseven.dbvis.K.B.L.doInBackground(Z:1521)
          	at javax.swing.SwingWorker$1.call(SwingWorker.java:295)
          	at java.util.concurrent.FutureTask.run(FutureTask.java:266)
          	at javax.swing.SwingWorker.run(SwingWorker.java:334)
          	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)
          	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)
          	at java.lang.Thread.run(Thread.java:745)
          
          risdenk Kevin Risden added a comment -

          Improves on Trey Cahill's patch. His patch and subsequent manual testing with DbVisualizer uncovered an issue with getSchemas. We shouldn't be returning any schema information since we don't have the concept of schemas. getTables is really what we want and this is now implemented in a TablesStream.

          This is a change to what is returned is returned by the JDBC driver. This should be put into Solr 6 before the release so we don't have to deal with backwards compatibility issues.

          risdenk Kevin Risden added a comment -

          Fix usage of get/set Schema in ConnectionImpl.

          risdenk Kevin Risden added a comment -

          Add test file that was missed on previous patch.

          cahilltr Trey Cahill added a comment -

          Added the ability for Collection Aliases to be considered their own databases and added tests as needed.

          cahilltr Trey Cahill added a comment -

          Was seeing NPE's at times when using DBVisualizer made calls to getTables(). Was able to trace the issue back to a null ZKStateReader in the cloudSolrClient. Calling cloudSolrClient.connect() prevents this from happening.

          joel.bernstein Joel Bernstein added a comment - - edited

          Just read the patch but haven't applied it yet. I think it looks pretty good I'll try to make some time to apply it today and test it out.

          We should probably hold off on collection alias support because the streaming API doesn't yet support aliases. So I don't believe SolrCloud aliases are queryable in the SQLHandler.

          One other very small thing is the TablesStream might make more sense as the TableStream, where each Tuple returns a single Table.

          cahilltr Trey Cahill added a comment -

          Joel Bernstein I removed alias support and renamed TablesStreams to TableStream. Also updated the get on cloudSolrClient.getZKStateReader() to only get once instead of twice.

          joel.bernstein Joel Bernstein added a comment -

          Ok things are looking pretty good to me.

          jira-bot ASF subversion and git services added a comment -

          Commit dbee6591741ab5aecf3a75326a9db126aa8cd0c4 in lucene-solr's branch refs/heads/master from Kevin Risden
          [ https://git-wip-us.apache.org/repos/asf?p=lucene-solr.git;h=dbee659 ]

          SOLR-8819: Implement DatabaseMetaDataImpl getTables() and fix getSchemas(). (Trey Cahill, Joel Bernstein, Kevin Risden)

          jira-bot ASF subversion and git services added a comment -

          Commit 39270d9df8959067a18edfe7c1e3cdb24adce543 in lucene-solr's branch refs/heads/branch_6x from Kevin Risden
          [ https://git-wip-us.apache.org/repos/asf?p=lucene-solr.git;h=39270d9 ]

          SOLR-8819: Implement DatabaseMetaDataImpl getTables() and fix getSchemas(). (Trey Cahill, Joel Bernstein, Kevin Risden)

          jira-bot ASF subversion and git services added a comment -

          Commit 658b2a4a925ed694a2c11add8c1bb81de1525294 in lucene-solr's branch refs/heads/branch_6_0 from Kevin Risden
          [ https://git-wip-us.apache.org/repos/asf?p=lucene-solr.git;h=658b2a4 ]

          SOLR-8819: Implement DatabaseMetaDataImpl getTables() and fix getSchemas(). (Trey Cahill, Joel Bernstein, Kevin Risden)


            People

            • Assignee:
              risdenk Kevin Risden
              Reporter:
              risdenk Kevin Risden
            • Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development