Improve logging output by ZkStateReader, by adding the following:
- Use LOG.foo() with parameters properly (i.e. not concatenating strings w/ +)
- Surround parameters with , to help readability, especially w/ empty values
- Add missing string messages, where I felt a message will clarify
- Convert some try-catch to a try-multicatch and improve output log message
Also, clean up dead code.