Solr
  1. Solr
  2. SOLR-8150

Fix build failure due to too much printout from QueryResponseTest

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 5.3, 6.0
    • Fix Version/s: 5.4, 6.0
    • Component/s: Tests
    • Labels:
      None

      Description

      Jenkins failure:

      9. okt. 2015 kl. 08.19 skrev Apache Jenkins Server <jenkins@builds.apache.org>:
      
      Build: https://builds.apache.org/job/Lucene-Solr-Tests-trunk-Java8/463/
      
      1 tests failed.
      FAILED:  junit.framework.TestSuite.org.apache.solr.client.solrj.response.QueryResponseTest
      
      Error Message:
      The test or suite printed 8730 bytes to stdout and stderr, even though the limit was set to 8192 bytes. Increase the limit with @Limit, ignore it completely with @SuppressSysoutChecks or run with -Dtests.verbose=true
      
      Stack Trace:
      java.lang.AssertionError: The test or suite printed 8730 bytes to stdout and stderr, even though the limit was set to 8192 bytes. Increase the limit with @Limit, ignore it completely with @SuppressSysoutChecks or run with -Dtests.verbose=true
      	at __randomizedtesting.SeedInfo.seed([96A3A8B2A4180026]:0)
      	at org.apache.lucene.util.TestRuleLimitSysouts.afterIfSuccessful(TestRuleLimitSysouts.java:212)
      	at com.carrotsearch.randomizedtesting.rules.TestRuleAdapter$1.afterIfSuccessful(TestRuleAdapter.java:36)
      	at com.carrotsearch.randomizedtesting.rules.StatementAdapter.evaluate(StatementAdapter.java:37)
      	at org.apache.lucene.util.TestRuleAssertionsRequired$1.evaluate(TestRuleAssertionsRequired.java:54)
      	at org.apache.lucene.util.TestRuleMarkFailure$1.evaluate(TestRuleMarkFailure.java:48)
      	at org.apache.lucene.util.TestRuleIgnoreAfterMaxFailures$1.evaluate(TestRuleIgnoreAfterMaxFailures.java:65)
      	at org.apache.lucene.util.TestRuleIgnoreTestSuites$1.evaluate(TestRuleIgnoreTestSuites.java:55)
      	at com.carrotsearch.randomizedtesting.rules.StatementAdapter.evaluate(StatementAdapter.java:36)
      	at com.carrotsearch.randomizedtesting.ThreadLeakControl$StatementRunner.run(ThreadLeakControl.java:367)
      	at java.lang.Thread.run(Thread.java:745)
      

      Fix by adding @Limit(bytes=20000) to class QueryResponseTest

      This applies to both Trunk and 5.x, and is easily reproducible on OSX.

        Activity

        ASF subversion and git services added a comment -

        Commit 1707813 from janhoy@apache.org in branch 'dev/trunk'
        [ https://svn.apache.org/r1707813 ]

        SOLR-8150: Fix build failure due to too much output from QueryResponseTest

        Joel Bernstein added a comment -

        Probably would be good to commit this so we can get things passing again.

        I was looking for a change that caused this test to start failing but I don't see one.

        Joel Bernstein added a comment - - edited

        Ah, just saw the commit. Thanks!

        ASF subversion and git services added a comment -

        Commit 1707817 from janhoy@apache.org in branch 'dev/branches/branch_5x'
        [ https://svn.apache.org/r1707817 ]

        SOLR-8150: Fix build failure due to too much output from QueryResponseTest (backport)

        Jan Høydahl added a comment -

        Could be that we should dig to see if there is some unwanted logging going on?
        But since the failed test merely exceeded the 8192 bytes limit I figured a small limit increase was the way to go as a first step.


          People

          • Assignee:
            Jan Høydahl
            Reporter:
            Jan Høydahl
          • Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development