The undistributed case i.e. solr/Grouping.java's variable names confusingly differ from the names used by lucene (and by the distributed case).
Specifically the name groupSort in lucene (and in the distributed case) means between-groups-sort but in the Grouping.java it means within-group-sort.
This JIRA proposes to rename the Grouping.java variables to remove the confusion:
- part 1: in Grouping.java rename groupSort to withinGroupSort
- part 2: in Grouping.java rename sort to groupSort