Solr
  1. Solr
  2. SOLR-8095

Allow disabling HDFS Locality Metrics

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 5.4, 6.0
    • Component/s: hdfs
    • Labels:

      Description

      We added metrics, but not a way to configure/turn them off.

        Activity

        Mark Miller added a comment -

        Is this changing the default from on to off?

        Mike Drob added a comment -

        Yea, it seems like some folks were surprised that the feature was defaulted on to begin with, so this is correcting what was probably a mistake initially.

        Mark Miller added a comment -

        Normally I'd worry about back compat, but probably okay in this case?

        Edward Ribeiro added a comment - - edited

        Mike Drob Don't want to preach to the choir, but what about changing the constant name to LOCALITY_METRICS_ENABLED? Easy to read in imho.

        Otis Gospodnetic added a comment -

        But why does having these metrics bother anyone? Never heard of turning metrics on/off. If it's just sitting there in JMX, it shouldn't bother any one, unless they are very expensive to compute or....?

        Mike Drob added a comment -

        If you have a rapidly changing index then it can take a long time to generate the metrics, since we lose out on the benefits of caching the info then. It's also relatively slow when starting up with a large existing index.

        The combination of these two indicates that this should be optional until we have a better understanding of what's happening, and why it's slow.

        Mark Miller added a comment -

        The problem is that getting metrics like this is per file and so very network chatty and slow.

        If you have a rapidly changing index then it can take a long time to generate the metrics, since we lose out on the benefits of caching the info then.

        For this type of data, I think we would prefer stale data to this limitation. Perhaps we should be doing time based caching instead. Fairly trappy to have this work okay on fairly static indexes and then cause a major performance issue as you move towards NRT settings.

        ASF subversion and git services added a comment -

        Commit 1706302 from Mark Miller in branch 'dev/trunk'
        [ https://svn.apache.org/r1706302 ]

        SOLR-8095: Allow disabling HDFS Locality Metrics and disable by default as it may have performance implications on rapidly changing indexes.

        ASF subversion and git services added a comment -

        Commit 1706307 from Mark Miller in branch 'dev/branches/branch_5x'
        [ https://svn.apache.org/r1706307 ]

        SOLR-8095: Allow disabling HDFS Locality Metrics and disable by default as it may have performance implications on rapidly changing indexes.

        Mark Miller added a comment -

        Thanks Mike! We should probably open another issue and look at using a pure time based caching system. This data does not really need to be real time.


          People

          • Assignee:
            Mark Miller
            Reporter:
            Mike Drob
          • Votes:
            0 Vote for this issue
            Watchers:
            5 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development