Uploaded image for project: 'Solr'
  1. Solr
  2. SOLR-7880

Update commons-cli to 1.4

Agile BoardAttach filesAttach ScreenshotVotersWatch issueWatchersCreate sub-taskLinkCloneUpdate Comment AuthorReplace String in CommentUpdate Comment VisibilityDelete Comments
    XMLWordPrintableJSON

Details

    • Improvement
    • Status: Closed
    • Major
    • Resolution: Fixed
    • 5.2.1
    • 8.6
    • scripts and tools
    • None

    Description

      While looking at SOLR-7847, I noticed that commons-cli was an old version, and once I upgraded it in the ivy config, found that SolrCLI is using deprecated classes/methods.

      This issue is to complete the upgrade and fix the deprecations.

      Attachments

        1. SOLR-7880.patch
          38 kB
          Shawn Heisey
        2. SOLR-7880.patch
          37 kB
          Shawn Heisey
        3. SOLR-7880.patch
          27 kB
          Shawn Heisey

        Activity

          This comment will be Viewable by All Users Viewable by All Users
          Cancel

          People

            erickerickson Erick Erickson
            elyograg Shawn Heisey
            Votes:
            0 Vote for this issue
            Watchers:
            6 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved:

              Slack

                Issue deployment