Solr
  1. Solr
  2. SOLR-7666

Umbrella ticket for Angular JS post-5.2.1 issues

    Details

    • Type: New Feature New Feature
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 5.3, 6.0
    • Fix Version/s: None
    • Component/s: UI
    • Labels:
      None

      Description

      As of Solr 5.2.1, there's a new admin UI available that has been written almost entirely by Upayavira (thanks!) over the last several months. It's written in Angular JS with an eye towards enhancement/maintainability. The default UI is still the old version, but you can access the new version by going to http://<sever:port>/solr/index.html. There are a couple of fixes between 5.2.0 and 5.2.1, so please use either a fresh 5x checkout, trunk, or 5.2.1....

      The expectation is that in Solr 5.3, the new code will become the default with the old UI deprecated and eventually removed.

      So it would be a great help if volunteers could give the new UI a spin. It should look much the same as the current one at the start, but evolve into something much more interesting and more cloud-friendly. Of course all the new UI code will always be available on trunk/6.0 too, and the up-to-date code will always be on both the trunk and 5x branches.

      Please provide feedback on the user's (or dev) lists about anything you find that doesn't work, or enhancements you'd like to see (or, even better, contribute). If you raise a JIRA, please link it to this one so I can keep track of what needs to be committed. If linking JIRAs is a mystery just add a comment to this JIRA referencing the new JIRA and we can take care of it.

      Please do not attach patches to this JIRA, it'll be much easier to keep track of everything if the patches are attached to sub-JIRAs.

      And a big thanks to Upayavira for this work!

      1. admin-ui-7666.zip
        1.13 MB
        Upayavira
      2. SOLR-7666.patch
        14 kB
        Upayavira
      3. SOLR-7666-3.patch
        3 kB
        Upayavira
      4. SOLR-7666-4.patch
        5 kB
        Upayavira
      5. SOLR-7666-5.patch
        2 kB
        Upayavira
      6. SOLR-7666-part2.patch
        7 kB
        Upayavira
      7. SOLR-7666-part2.patch
        7 kB
        Upayavira

        Issue Links

          Activity

          Erick Erickson added a comment -

          Other suggestions for things that might be folded into the new UI, here for reference.

          Upayavira added a comment -

          Patch fixes both issues (bleeding left and unmatching label names)

          Edward Ribeiro added a comment -

          Adding this issue to the todo list of the new UI as the old one is gonna be retired eventually.

          Upayavira added a comment -

          Can now assign tickets to myself so closing this ticket as it isn't needed for tracking anymore.

          ASF subversion and git services added a comment -

          Commit 1694429 from Upayavira in branch 'dev/trunk'
          [ https://svn.apache.org/r1694429 ]

          SOLR-7666 Update CHANGES.txt for Angular UI changes

          ASF subversion and git services added a comment -

          Commit 1694430 from Upayavira in branch 'dev/branches/branch_5x'
          [ https://svn.apache.org/r1694430 ]

          SOLR-7666: Update CHANGES.txt for fixes to AngularJS admin UI

          ASF subversion and git services added a comment -

          Commit 1694455 from Upayavira in branch 'dev/branches/lucene_solr_5_3'
          [ https://svn.apache.org/r1694455 ]

          SOLR-7666: Update CHANGES.txt to include angularJS admin UI fixes

          Alexandre Rafalovitch added a comment -

          When clicking from term value link to the query screen, it does not seem that the query value is actually used.

          Reproduction:
          *) Solr 5.3, techproducts example
          *) http://localhost:8983/solr/index.html#/techproducts/schema-browser?field=cat
          *) Load Term Info
          *) Click on 'electronics' or any other
          *) We go to http://localhost:8983/solr/index.html#/techproducts/query?q=cat:electronics
          *) The search screen shows no results and boxes are not pre-populated with the *cat:electronics'"

          Alexandre Rafalovitch added a comment -

          (Solr 5.3, Windows, Chrome) Logging screen, once visited, does not stop calling XHR even when navigating to the other screens.

          E.g. http://localhost:8983/solr/admin/info/logging?_=1442346075922&since=0&wt=json (every 10 seconds)

          Alexandre Rafalovitch added a comment -

          (Solr 5.3, Windows, Chrome) Documents screen is not working when clicking Submit Document button. Seems to happen with JSON and Document Builder types. Others seem to react. The exception trace in the console:

          ReferenceError: callack is not defined
          at Scope.$scope.submit (documents.js:119)
          at $parseFunctionCall (angular.js:12355)
          at callback (angular.js:22972)
          at Scope.$eval (angular.js:14406)
          at Scope.$apply (angular.js:14505)
          at HTMLButtonElement.<anonymous> (angular.js:22977)
          at HTMLButtonElement.n.event.dispatch (jquery-2.1.3.min.js:28)
          at HTMLButtonElement.r.handle (jquery-2.1.3.min.js:28)

          Alexandre Rafalovitch added a comment -

          (Solr 5.3, Windows, Chrome and Firefox), Dashboard screen:
          The bars under System (all three) are uniform color and missing size information. Just grey bars. The same instance in default UI shows usage percentages, bar is partially filled, etc.

          JVM/Args parameter is empty. In default UI, it has a long list of values. The other two values (Runtime and Processors) are ok.

          Upayavira added a comment -

          Additional minor bugs found, re-opening

          Alexandre Rafalovitch added a comment -

          Core Admin screen

          • is missing Optimize button.
          • deletedDocs shows 0, where present UI shows - (dash)
          Alexandre Rafalovitch added a comment -

          Schema Browser screen: dropdown list is not sorted.

          Alexandre Rafalovitch added a comment -

          Query screen: Default query is different both in reality and in copy-able/display version:

          Differences in Angular (Chrome Network monitor for "real" part):

          • indent=on (instead of true)
          • display URL duplicates the URI components
          • real URL uses doNotIntercept=true instead of timestamp
          • real URL has escape for the last slash in the URL component but not in query value
          Alexandre Rafalovitch added a comment - - edited

          Query screen

          • indent check seems to be miswired. Shows unchecked on load, despite flag actually being on. Trying to check/uncheck it removes the flag from the query whatever the check mark shows. Probably related to the comment above (check=on vs. check=true)
          • debugQuery check also does not seem to affect the actual query
          • facet check also thinks it is on vs. true in current UI
          Upayavira added a comment -

          should be resolved shortly

          Upayavira added a comment -

          should be resolved shortly. Same issue for DIH, Segments and Replication. I've done them all except replication.

          Upayavira added a comment -

          should be resolved shortly

          Upayavira added a comment -

          Optimize is now deliberately hidden when there are no deletions. Whilst 0 vs - is different, they are both right so I'm gonna leave this one alone.

          Upayavira added a comment -

          should be resolved shortly

          Upayavira added a comment -

          indent, sort, debugQuery all fixed, and facet/highlighting/spellcheck switched from on to true.

          Upayavira added a comment -

          I can't do all of this one - indent has switched to true, the duplication is removed, and the parameters are (I think) in the same order now (sorted).

          I cannot fix the escaped slash - it is encoded within Angular, and I'd love to find a way to remove the doNotIntercept param - but it is needed to tell the 'service' not to handle an exception.

          Upayavira added a comment -

          There's a separate ticket for this one (SOLR-7686). I haven't been able to replicate it. It'd really help if you could paste against that ticket, the JSON returned in the back-end for the old and new UIs, thx!

          Upayavira added a comment -

          Patch that fixes all but the dashboard issue.

          Upayavira added a comment -

          Here's a zip of the entire UI - you should be able to replace the server/solr-webapp/webapp dir with this one in a running Solr 5.3 and you should be see these issues resolved. Thanks for such a wonderful set of bugs, please - send any more that you find!

          ASF subversion and git services added a comment -

          Commit 1703379 from Upayavira in branch 'dev/trunk'
          [ https://svn.apache.org/r1703379 ]

          SOLR-7666 A motley collection of bugs in angular UI

          ASF subversion and git services added a comment -

          Commit 1703380 from Upayavira in branch 'dev/branches/branch_5x'
          [ https://svn.apache.org/r1703380 ]

          SOLR-7666 A motley collection of bugs in angular UI

          Alexandre Rafalovitch added a comment -

          New UI version now complains loudly about "healthcheck not configured", which seems to be new way to expose an error that was there before as well. Specifically, the following URL gets 503 response:
          http://localhost:8983/solr/techproducts/admin/ping?_=1442412319984&action=status&ts=1442412319984&wt=json

          The cause seems to be action=status parameter. When clicking on ping directly, that parameter is missing.

          Alexandre Rafalovitch added a comment -

          indent=false still does indent. The current UI skips indent flag all together when it is unset.

          Alexandre Rafalovitch added a comment -

          CSS/icon requests include $

          {version} parameter which is NOT resolved to a timestamp (which I assume is what it should do). So, on the Dashboard page we get URL requests like:
          * http://localhost:8983/solr/css/angular/replication.css?_=${version}
          Alexandre Rafalovitch added a comment -

          I understand the need for doNotIntercept, but looking at the code it should be stripped from the actual request. But I see it in the round-trip parameter list:

          "responseHeader":{
          "status":0,
          "QTime":0,
          "params":{
          "q":":",
          "doNotIntercept":"true",
          "indent":"true",
          "wt":"json",
          "_":"1442414864269"}},

          Upayavira added a comment -

          I'm reverting to indent=on, because indent=off actually switches indenting off!! - although, it won't show indent=off in the URL.

          I've also made the 'debugQuery' and 'indent' labels clickable.

          Upayavira added a comment -

          Finally investigating this - this is a feature of the Java code that serves it. I moved index.html over to admin.html, and suddenly {{$

          {version}

          }} was replaced with 6.0.0 (for trunk). We will want to extend whatever Java code is doing that to do the same for our new UI.

          Upayavira added a comment -

          The issue is that the calling side needs to tell an angular interceptor that it mustn't do anything - just pass the error back unhandled. I was using the request parameter as a method to achieve this. Reading the docs further, I see I can also set a request header, which is also available to the angular interceptor code. Therefore, I have switched usage of doNotIntercept to be an http request header, and thus it won't show in the URL or in the parameter list any more.

          Thanks for bugging me on this!

          Upayavira added a comment -

          Here's a patch that:

          • switches 'true' back to 'on' and ensures 'off' doesn't show in URL params
          • switches doNotIntercept to be a request header, not a request param
          • clears exceptions on route (tab) change
          • removes some extraneous and potentially confusing value="true" entries on checkboxes. Angular ignores these.

          Rather than clutter JIRA with heaps of webapp zips, I will maintain an up-to-date copy at http://people.apache.org/~upayavira/webapp.zip

          Upayavira added a comment -

          I've attached a new "part2" patch and uploaded a new webapp.zip that changes web.xml so that the new UI is served with $

          {version}

          replaced. More importantly, the new UI now sets the X-Frame-Options anti-clickjacking header.

          You will need to restart your Solr for this change to take effect.

          Shawn Heisey added a comment -

          On the "Query" tab, it is not obvious to a beginner that the "q" parameter is where the query goes. A seasoned admin/dev will know intuitively that q means query, but I don't think we can count on that. I'm thinking I should open an issue for this, just looking for confirmation.

          I thought we had tooltips for most of these parameters, but they do not seem to be present now. Some of the other parameters could use clarification too:

          • q: Query
          • fq: Filter Query
          • wt: Writer (or is that Write Transformer?)
          • df: Default Field
          • fl: Field List

          Those are just examples from the main input boxes. Other parameters (like those for dismax) might need clarification too, but I don't want the UI to get too cluttered.

          Upayavira added a comment -

          This ticket is more about making sure it works rather than that it is good.

          I agree that the query tab is difficult in that it expects you to know what all these options mean. I'd love to see a new take on the query tab - a bit more akin to what /browse does - a more traditional query interface. But it'd take quite some thinking as to how to make it generic and work across all datasets.

          Please do create a new ticket for this. I'm thinking about a "query builder" that allows you to pick from a list of fields to query, then type in terms you want to query from those fields, and it spits out a query string, much like the query UI currently spits out a URL.

          ASF subversion and git services added a comment -

          Commit 1703798 from Upayavira in branch 'dev/trunk'
          [ https://svn.apache.org/r1703798 ]

          SOLR-7666 - query pane and index.html serving tweaks

          ASF subversion and git services added a comment -

          Commit 1703799 from Upayavira in branch 'dev/branches/branch_5x'
          [ https://svn.apache.org/r1703799 ]

          SOLR-7666 - query pane and index.html serving tweaks

          Alexandre Rafalovitch added a comment -

          Using the latest zip:

          • When using admin.html instead of index.html, the version numbers are resolved. But also, the JVM args and the memory bars are populated too. Related?
          • Ping (described earlier) still seems to get an error message in the network panel, though the Healthcheck error is gone
          • There is still many jquery scripts being loaded (on admin.html) page
          • I no longer see doNotIntercept anywhere, not even in the request headers. Hopefully, it is stripped out by the Angular, but I am not sure how to check for that.
          ASF subversion and git services added a comment -

          Commit 1704195 from Upayavira in branch 'dev/trunk'
          [ https://svn.apache.org/r1704195 ]

          SOLR-7666 Revert web.xml as old UI loading against new URL

          ASF subversion and git services added a comment -

          Commit 1704196 from Upayavira in branch 'dev/branches/branch_5x'
          [ https://svn.apache.org/r1704196 ]

          SOLR-7666 Revert web.xml as old UI loading against new URL

          Upayavira added a comment -

          Using the latest zip, web.xml change caused the old UI to be loaded against the new URL. I've reverted this, and uploaded a new zip with that feature removed. See SOLR-8074 for follow up on this issue.

          Alexandre Rafalovitch please retry all your tests with the new zip - your previous comment was all made against the wrong UI

          Alexandre Rafalovitch added a comment -

          Is this definitely the new zip? Because JIRA says the zip is 5 days old.

          Upayavira added a comment -

          Alexandre Rafalovitch use the one here: http://people.apache.org/~upayavira/webapp.zip (don't want to clog JIRA with lots of 1Mb zip files)

          Alexandre Rafalovitch added a comment -

          Using the zip at the URL on top of 4.3.1 with URL: http://localhost:8983/solr/index.html#/

          • Angular error in the logs for the dashboard screen:

            TypeError: Cannot read property '0' of null
            at index.js:27
            at angular-resource.min.js:33
            at processQueue (angular.js:13193)
            at angular.js:13209
            at Scope.promises.$get.Scope.$eval (angular.js:14406)
            at Scope.promises.$get.Scope.$digest (angular.js:14222)
            at Scope.promises.$get.Scope.$apply (angular.js:14511)
            at done (angular.js:9669)
            at completeRequest (angular.js:9859)
            at XMLHttpRequest.requestLoaded (angular.js:9800)

          • versions are not resolved
          • args and bars are not working
          • healthcheck message is still there
          • the query now has doNotIntercept in the request headers
          • Logging now seems to return nothing at all though the calls are going out and coming back. Initial call missing?
          • indent/debug checkboxes seem to work now.
          Upayavira added a comment -

          Re stacktrace, see patch in SOLR-7686, I believe that will fix that issue - thanks for the very useful stack trace!

          I'd imagine the args and bars will now show up, as the code doesn't hit an exception.

          Versions will not be resolved until we sort out the LoadAdminUIServlet (a different ticket)

          I'll now look at logging and healthcheck message, which seems to be what's left for this ticket.

          Upayavira added a comment -

          Alexandre Rafalovitch I've tried my own system, and I'm not getting the healthcheck message, and logging is working for me. I triggered a logging event with this URL:

          http://localhost:8983/solr/images/select?q=[

          Could you try that (change the core name of course) and see whether logging works, or whether you get any exceptions/stacktraces?

          I did a bit more digging into "ping" support. I didn't realise the possibility of configuring a file that will take a node/core out of a load balancer, but the nice thing is, when you add the relevant stuff to solrconfig.xml, the UI behaves as it should, even though it was never tested

          Please try with the latest trunk, or lucene_5x branch, and let me know if you see any more healthcheck issues.

          Thanks!

          Upayavira added a comment -

          schema-browser tab shows stuff on the right that should be hidden if no field has been selected. Fix coming.

          ASF subversion and git services added a comment -

          Commit 1707259 from Upayavira in branch 'dev/trunk'
          [ https://svn.apache.org/r1707259 ]

          SOLR-7666 Hide right hand side when no field selected in schema browser

          ASF subversion and git services added a comment -

          Commit 1707264 from Upayavira in branch 'dev/branches/branch_5x'
          [ https://svn.apache.org/r1707264 ]

          SOLR-7666 Hide right hand side when no field selected in schema browser

          ASF subversion and git services added a comment -

          Commit 1707269 from Upayavira in branch 'dev/trunk'
          [ https://svn.apache.org/r1707269 ]

          SOLR-4388 SOLR-7858 SOLR-7666 update CHANGES.txt

          ASF subversion and git services added a comment -

          Commit 1707270 from Upayavira in branch 'dev/branches/branch_5x'
          [ https://svn.apache.org/r1707270 ]

          SOLR-4388 SOLR-7858 SOLR-7666 update CHANGES.txt

          Upayavira added a comment -

          Patch that:

          • fixes healthcheck issue - exception is now caught and presented correctly
          • prevents luke from complaining about MultiBits class not being found
          • resolves minor HTML label mismatch in cores.html
          ASF subversion and git services added a comment -

          Commit 1707463 from Upayavira in branch 'dev/trunk'
          [ https://svn.apache.org/r1707463 ]

          SOLR-7666 Resolve exceptions and tidy HTML label name

          ASF subversion and git services added a comment -

          Commit 1707464 from Upayavira in branch 'dev/branches/branch_5x'
          [ https://svn.apache.org/r1707464 ]

          SOLR-7666 Resolve exceptions and tidy HTML label name

          Upayavira added a comment -

          Patch that:

          • fix collection overview link
          • resolve healthcheck issue
          • sort files in files tab
          • make raw params in query pane work
          • make facets, hl and spellcheck work on query pane (eeks)
          • use placeholder for “new_collection” on collections tab
          ASF subversion and git services added a comment -

          Commit 1709707 from Upayavira in branch 'dev/trunk'
          [ https://svn.apache.org/r1709707 ]

          SOLR-7666 Multiple minor fixes

          ASF subversion and git services added a comment -

          Commit 1709708 from Upayavira in branch 'dev/branches/branch_5x'
          [ https://svn.apache.org/r1709708 ]

          SOLR-7666 Multiple minor fixes

          ASF subversion and git services added a comment -

          Commit 1709711 from Upayavira in branch 'dev/trunk'
          [ https://svn.apache.org/r1709711 ]

          SOLR-7666 Re-fix some accidentally reverted changes

          ASF subversion and git services added a comment -

          Commit 1709712 from Upayavira in branch 'dev/branches/branch_5x'
          [ https://svn.apache.org/r1709712 ]

          SOLR-7666 Re-fix some accidentally reverted changes

          Upayavira added a comment -

          Small patch that:

          • analysis: makes verbose checkbox update query string
          • query: executes query if request param contains query text
          ASF subversion and git services added a comment -

          Commit 1712539 from Upayavira in branch 'dev/trunk'
          [ https://svn.apache.org/r1712539 ]

          SOLR-7666 Fix URL handling in query and analysis panes

          ASF subversion and git services added a comment -

          Commit 1712540 from Upayavira in branch 'dev/branches/branch_5x'
          [ https://svn.apache.org/r1712540 ]

          SOLR-7666 Fix URL handling in query and analysis panes

          Erick Erickson added a comment -

          Collecting here...

          Erick Erickson added a comment -

          Hmmm, this ticket is getting rather long (and somewhat outdated). Should we go ahead and close it and start another umbrella ticket for "Post Solr 5.4)?

          Upayavira added a comment -

          As Erick says, this ticket is rather long, any new issues should be in new tickets.


            People

            • Assignee:
              Upayavira
              Reporter:
              Erick Erickson
            • Votes:
              0 Vote for this issue
              Watchers:
              6 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development