Uploaded image for project: 'Solr'
  1. Solr
  2. SOLR-7362

TestReqParamsAPI failing in jenkins

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 6.2.1, 6.3
    • Component/s: None
    • Labels:
      None

      Description

      Build: http://jenkins.thetaphi.de/job/Lucene-Solr-trunk-Windows/4645/
      Java: 32bit/jdk1.8.0_40 -server -XX:+UseSerialGC
      
      1 tests failed.
      FAILED:  org.apache.solr.handler.TestReqParamsAPI.test
      
      Error Message:
      Could not get expected value  'null' for path 'response/params/y/p' full output: {   "responseHeader":{     "status":0,     "QTime":1},   "response":{     "znodeVersion":3,     "params":{       "x":{         "a":"A val",         "b":"B val",         "":{"v":0}},       "y":{         "p":"P val",         "q":"Q val",         "":{"v":0}}}}}
      
      Stack Trace:
      java.lang.AssertionError: Could not get expected value  'null' for path 'response/params/y/p' full output: {
        "responseHeader":{
          "status":0,
          "QTime":1},
        "response":{
          "znodeVersion":3,
          "params":{
            "x":{
              "a":"A val",
              "b":"B val",
              "":{"v":0}},
            "y":{
              "p":"P val",
              "q":"Q val",
              "":{"v":0}}}}}
              at __randomizedtesting.SeedInfo.seed([D0DB18ECE165C505:588F27364F99A8FD]:0)
              at org.junit.Assert.fail(Assert.java:93)
              at org.junit.Assert.assertTrue(Assert.java:43)
              at org.apache.solr.core.TestSolrConfigHandler.testForResponseElement(TestSolrConfigHandler.java:405)
              at org.apache.solr.handler.TestReqParamsAPI.testReqParams(TestReqParamsAPI.java:236)
              at org.apache.solr.handler.TestReqParamsAPI.test(TestReqParamsAPI.java:71)
      
      1. SOLR-7362.patch
        11 kB
        Varun Thacker

        Activity

        jira-bot ASF subversion and git services added a comment -

        Commit 1672991 from shalin@apache.org in branch 'dev/trunk'
        [ https://svn.apache.org/r1672991 ]

        SOLR-7362: Added @BadApple annotation

        jira-bot ASF subversion and git services added a comment -

        Commit 1672992 from shalin@apache.org in branch 'dev/branches/branch_5x'
        [ https://svn.apache.org/r1672992 ]

        SOLR-7362: Added @BadApple annotation

        jira-bot ASF subversion and git services added a comment -

        Commit e069d31086116fa293f40155f9e96e0da9912c8f in lucene-solr's branch refs/heads/master from Noble Paul
        [ https://git-wip-us.apache.org/repos/asf?p=lucene-solr.git;h=e069d31 ]

        SOLR-7362

        noble.paul Noble Paul added a comment -

        non reproducible after so many runs , re-enabling the tests

        jira-bot ASF subversion and git services added a comment -

        Commit e069d31086116fa293f40155f9e96e0da9912c8f in lucene-solr's branch refs/heads/apiv2 from Noble Paul
        [ https://git-wip-us.apache.org/repos/asf?p=lucene-solr.git;h=e069d31 ]

        SOLR-7362

        jira-bot ASF subversion and git services added a comment -

        Commit 405e084a6c11d9cd23751ebf6a385b64a67b7d1f in lucene-solr's branch refs/heads/master from Noble Paul
        [ https://git-wip-us.apache.org/repos/asf?p=lucene-solr.git;h=405e084 ]

        SOLR-7362: enabling more logs

        dsmiley David Smiley added a comment -

        This fails for me reproducibly, on the 6x branch (if that matters?): -Dtests.seed=D204858DC237526B

        noble.paul Noble Paul added a comment -

        I just beasted it with the same seed fr 15 iters and it is not failing . Will try it later

        dsmiley David Smiley added a comment -

        Try running from within IntelliJ maybe? It's more reproducible from me when I do that (who knows why). And I have seen this on master too... but not 6.0.

        jira-bot ASF subversion and git services added a comment -

        Commit 05b38f5f21f18c0f38fbd0907ffd8b2bd8cf0132 in lucene-solr's branch refs/heads/master from Shalin Shekhar Mangar
        [ https://git-wip-us.apache.org/repos/asf?p=lucene-solr.git;h=05b38f5 ]

        SOLR-7362: Log the actual payload being sent to Solr

        varunthacker Varun Thacker added a comment -

        I've been looking at this test case and trying to figure out why it fails.

        This is what the ref guide says about the params api ( https://cwiki.apache.org/confluence/display/solr/Request+Parameters+API )

        To avoid a reload of your collection for small parameter changes.

        The current behaviour though is that after every request a core reload takes place. This happens because in ZkController#persistConfigResourceToZooKeeper we call touchConfDir . A core reload gets triggered because of it.

        Do we need to reload the core? Else I think we should fix that first.

        Its not a 100% clear to me yet, but my guess is that the request is coming to a node where the core is being reloaded and hence it doesn't know about the updated param

        noble.paul Noble Paul added a comment -

        Core is not reloaded when Params.json is modified

        varunthacker Varun Thacker added a comment -

        Hi Noble,

        Yes you're right. I was mistaken that the core is getting reload because of a /config/params action. The config API which is also being used in the test is whats causing the reload then.

        Not sure whats wrong then. I'll try digging deeper tomorrow

        varunthacker Varun Thacker added a comment -

        Test which moves the creation of request handlers to the start. Adding a request handler calls a core reload and incoming requests might not see the latest state.

        The race condition still exits. If we want to address that we should deal with it in another Jira and have a better concurrent test for validating it.

        For now this should fix the test failures. I'll commit this to master and track Jenkins failures for it.

        Other minor changes:
        Renamed checkStale -> isStale
        minor logging changes

        jira-bot ASF subversion and git services added a comment -

        Commit c513ae19997fd6ac78499a93c400706eec3d85cc in lucene-solr's branch refs/heads/master from Varun Thacker
        [ https://git-wip-us.apache.org/repos/asf?p=lucene-solr.git;h=c513ae1 ]

        SOLR-7362: Fix TestReqParamsAPI test failures

        jira-bot ASF subversion and git services added a comment -

        Commit f6162f3f00e1c1d0c756f5bd3f8cc4916bd01ccd in lucene-solr's branch refs/heads/branch_6x from Varun Thacker
        [ https://git-wip-us.apache.org/repos/asf?p=lucene-solr.git;h=f6162f3 ]

        SOLR-7362: Fix TestReqParamsAPI test failures

        shalinmangar Shalin Shekhar Mangar added a comment -

        Re-opening to backport to 6.2.1.

        This test failed while I was trying to build the artifacts. I think it is better to backport these fixes to make the release process smoother.

        jira-bot ASF subversion and git services added a comment -

        Commit d3069f04d7e8dd34e06dcbc0b06f391b2537b71f in lucene-solr's branch refs/heads/branch_6_2 from Shalin Shekhar Mangar
        [ https://git-wip-us.apache.org/repos/asf?p=lucene-solr.git;h=d3069f0 ]

        SOLR-7362: Log the actual payload being sent to Solr

        (cherry picked from commit 05b38f5)

        jira-bot ASF subversion and git services added a comment -

        Commit 1aea54f7f7bcf7ed947639411b90f89d95a80cf0 in lucene-solr's branch refs/heads/branch_6_2 from Varun Thacker
        [ https://git-wip-us.apache.org/repos/asf?p=lucene-solr.git;h=1aea54f ]

        SOLR-7362: Fix TestReqParamsAPI test failures

        (cherry picked from commit f6162f3)

        jira-bot ASF subversion and git services added a comment -

        Commit 62547669b5d319891740991842c314be85d40201 in lucene-solr's branch refs/heads/branch_6_2 from Shalin Shekhar Mangar
        [ https://git-wip-us.apache.org/repos/asf?p=lucene-solr.git;h=6254766 ]

        SOLR-7362: Added changelog entry

        shalinmangar Shalin Shekhar Mangar added a comment -

        Closing after 6.2.1 release


          People

          • Assignee:
            varunthacker Varun Thacker
            Reporter:
            noble.paul Noble Paul
          • Votes:
            0 Vote for this issue
            Watchers:
            6 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development