Uploaded image for project: 'Solr'
  1. Solr
  2. SOLR-6896

SolrJettyRunner blocks for 5 seconds on shutdown

    Details

    • Type: Improvement
    • Status: Resolved
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 5.0, 6.0
    • Fix Version/s: None
    • Component/s: Tests
    • Labels:
      None
    1. SOLR-6896.patch
      3 kB
      Alan Woodward

      Activity

      romseygeek Alan Woodward added a comment -

      I'm not sure what's causing this, but it's adding wasted time to the end of every distributed test we have in Solr.

      At the very least, we could shut down the various Jettys using a completion service so that we're only blocking for 5 seconds maximum, as opposed to 5 seconds per server.

      romseygeek Alan Woodward added a comment -

      The cause looks to be that server.join() waits for all threads in the QueuedThreadPool to close themselves, and the MaxIdleTime for the qtp is set to 5 seconds. Should we drop this down?

      shalinmangar Shalin Shekhar Mangar added a comment -

      The cause looks to be that server.join() waits for all threads in the QueuedThreadPool to close themselves, and the MaxIdleTime for the qtp is set to 5 seconds. Should we drop this down?

      +1

      Good catch!

      romseygeek Alan Woodward added a comment -

      Simple patch, dropping the 5 second idle timeout to 200ms. Running the full Solr test suite went from taking 16m25s to 12m45s, which is a nice speedup!

      markrmiller@gmail.com Mark Miller added a comment -

      I'd like to take a closer look at this as I think it will really affect my patch in SOLR-4509. I've seen a similar speedup, but even with a much higher timeout (60 seconds). Let me poke for a bit and I'll comment again.

      jira-bot ASF subversion and git services added a comment -

      Commit 1648387 from Alan Woodward in branch 'dev/trunk'
      [ https://svn.apache.org/r1648387 ]

      SOLR-6896: Drop SolrJettyRunner max idle time to 200ms to speed up tests

      jira-bot ASF subversion and git services added a comment -

      Commit 1648388 from Alan Woodward in branch 'dev/branches/branch_5x'
      [ https://svn.apache.org/r1648388 ]

      SOLR-6896: Drop SolrJettyRunner max idle time to 200ms to speed up tests

      romseygeek Alan Woodward added a comment -

      Argh, literally saw your comment the second I'd committed to 5x. Do you want me to revert?

      romseygeek Alan Woodward added a comment -

      I'm marking this as resolved for now - Mark Miller if you want to make any other changes, shout and I can reopen it.


        People

        • Assignee:
          romseygeek Alan Woodward
          Reporter:
          romseygeek Alan Woodward
        • Votes:
          0 Vote for this issue
          Watchers:
          4 Start watching this issue

          Dates

          • Created:
            Updated:
            Resolved:

            Development