Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 5.0
    • Fix Version/s: 5.0, 6.0
    • Component/s: Build
    • Labels:
      None

      Description

      Solr uses a really old version (3.2.7) of the Woddstox API, the current stable version being 4.4.1.

      This old version is packaged in the same jar with an equally old version of StAX2 API. This makes it difficult to update just the StAX API with a more recent version - in my application I ran into this when trying to use StAXON.

      I propose to update to Woodstox 4.4.1 and StAX2 3.1.4.

        Attachments

        1. SOLR-6830.diff
          2 kB
          Andrzej Bialecki

          Issue Links

            Activity

              People

              • Assignee:
                ab Andrzej Bialecki
                Reporter:
                ab Andrzej Bialecki
              • Votes:
                0 Vote for this issue
                Watchers:
                5 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: