JIRA for Jan's comments on
I thought we agreed to prefer the term "shard" over "slice", so I think we should do this for this API as well.
The only place in our refguide we use the word "slice" is in How SolrCloud Works  and that description is disputed.
The refguide explanation of what a shard is can be found in Shards and Indexing Data in SolrCloud , quoting:
When your data is too large for one node, you can break it up and store it in sections by creating one or more shards. Each is a portion of the logical index, or core, and it's the set of all nodes containing that section of the index.
So I'm proposing a rename of this API to BALANCESHARDUNIQUE and a rewrite of .
Note Mark's comment on that JIRA, but I think it would be best to continue to talk about "shards" with user-facing operations.