Solr
  1. Solr
  2. SOLR-6587

Misleading exception when creating collections in SolrCloud with bad configuration

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 4.10.1, 5.0, 6.0
    • Fix Version/s: 4.10.2, 5.0, 6.0
    • Component/s: None
    • Labels:
      None

      Description

      I uploaded a configuration in bad shape to Zookeeper, then tried to create a collection and I was getting:

      

      ERROR - 2014-10-03 16:48:25.712; org.apache.solr.core.CoreContainer; Error creating core [tflobbe_collection1_shard2_replica2]: Could not load conf for core tflobbe_collection1_shard2_replica2: ZkSolrResourceLoader does not support getConfigDir() - likely, what you are trying to do is not supported in ZooKeeper mode
      
      org.apache.solr.common.SolrException: Could not load conf for core tflobbe_collection1_shard2_replica2: ZkSolrResourceLoader does not support getConfigDir() - likely, what you are trying to do is not supported in ZooKeeper mode
      
              at org.apache.solr.core.ConfigSetService.getConfig(ConfigSetService.java:66)
      
              at org.apache.solr.core.CoreContainer.create(CoreContainer.java:489)
      
              at org.apache.solr.core.CoreContainer.create(CoreContainer.java:466)
      
              at org.apache.solr.handler.admin.CoreAdminHandler.handleCreateAction(CoreAdminHandler.java:575)
      
              at org.apache.solr.handler.admin.CoreAdminHandler.handleRequestInternal(CoreAdminHandler.java:199)
      
              at org.apache.solr.handler.admin.CoreAdminHandler.handleRequestBody(CoreAdminHandler.java:188)
      
              at org.apache.solr.handler.RequestHandlerBase.handleRequest(RequestHandlerBase.java:135)
      
              at org.apache.solr.servlet.SolrDispatchFilter.handleAdminRequest(SolrDispatchFilter.java:729)
      
              at org.apache.solr.servlet.SolrDispatchFilter.doFilter(SolrDispatchFilter.java:258)
      
              at org.apache.solr.servlet.SolrDispatchFilter.doFilter(SolrDispatchFilter.java:207)
      
              at org.eclipse.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1419)
      
              at org.eclipse.jetty.servlet.ServletHandler.doHandle(ServletHandler.java:455)
      
              at org.eclipse.jetty.server.handler.ScopedHandler.handle(ScopedHandler.java:137)
      
              at org.eclipse.jetty.security.SecurityHandler.handle(SecurityHandler.java:557)
      
              at org.eclipse.jetty.server.session.SessionHandler.doHandle(SessionHandler.java:231)
      
              at org.eclipse.jetty.server.handler.ContextHandler.doHandle(ContextHandler.java:1075)
      
              at org.eclipse.jetty.servlet.ServletHandler.doScope(ServletHandler.java:384)
      
              at org.eclipse.jetty.server.session.SessionHandler.doScope(SessionHandler.java:193)
      
              at org.eclipse.jetty.server.handler.ContextHandler.doScope(ContextHandler.java:1009)
      
              at org.eclipse.jetty.server.handler.ScopedHandler.handle(ScopedHandler.java:135)
      
              at org.eclipse.jetty.server.handler.ContextHandlerCollection.handle(ContextHandlerCollection.java:255)
      
              at org.eclipse.jetty.server.handler.HandlerCollection.handle(HandlerCollection.java:154)
      
              at org.eclipse.jetty.server.handler.HandlerWrapper.handle(HandlerWrapper.java:116)
      
              at org.eclipse.jetty.server.Server.handle(Server.java:368)
      
              at org.eclipse.jetty.server.AbstractHttpConnection.handleRequest(AbstractHttpConnection.java:489)
      
              at org.eclipse.jetty.server.BlockingHttpConnection.handleRequest(BlockingHttpConnection.java:53)
      
              at org.eclipse.jetty.server.AbstractHttpConnection.content(AbstractHttpConnection.java:953)
      
              at org.eclipse.jetty.server.AbstractHttpConnection$RequestHandler.content(AbstractHttpConnection.java:1014)
      
              at org.eclipse.jetty.http.HttpParser.parseNext(HttpParser.java:861)
      
              at org.eclipse.jetty.http.HttpParser.parseAvailable(HttpParser.java:240)
      
              at org.eclipse.jetty.server.BlockingHttpConnection.handle(BlockingHttpConnection.java:72)
      
              at org.eclipse.jetty.server.bio.SocketConnector$ConnectorEndPoint.run(SocketConnector.java:264)
      
              at org.eclipse.jetty.util.thread.QueuedThreadPool.runJob(QueuedThreadPool.java:608)
      
              at org.eclipse.jetty.util.thread.QueuedThreadPool$3.run(QueuedThreadPool.java:543)
      
              at java.lang.Thread.run(Thread.java:745)
      
      Caused by: org.apache.solr.common.cloud.ZooKeeperException: ZkSolrResourceLoader does not support getConfigDir() - likely, what you are trying to do is not supported in ZooKeeper mode
      
              at org.apache.solr.cloud.ZkSolrResourceLoader.getConfigDir(ZkSolrResourceLoader.java:101)
      
              at org.apache.solr.core.SolrConfig.readFromResourceLoader(SolrConfig.java:147)
      
              at org.apache.solr.core.ConfigSetService.createSolrConfig(ConfigSetService.java:80)
      
              at org.apache.solr.core.ConfigSetService.getConfig(ConfigSetService.java:61)
      
              ... 34 more
      
      
      
      1. SOLR-6587.patch
        3 kB
        Tomás Fernández Löbbe

        Activity

        ASF subversion and git services added a comment -

        Commit 1629305 from Tomás Fernández Löbbe in branch 'dev/trunk'
        [ https://svn.apache.org/r1629305 ]

        SOLR-6587: Correct exception thrown on bad collection configuration in SolrCloud mode

        ASF subversion and git services added a comment -

        Commit 1629311 from Tomás Fernández Löbbe in branch 'dev/branches/branch_5x'
        [ https://svn.apache.org/r1629311 ]

        SOLR-6587: Correct exception thrown on bad collection configuration in SolrCloud mode

        Jan Høydahl added a comment -

        Candidate for 4.10.2?

        Tomás Fernández Löbbe added a comment -

        Yes, I'll merge it today

        ASF subversion and git services added a comment -

        Commit 1633735 from Tomás Fernández Löbbe in branch 'dev/branches/lucene_solr_4_10'
        [ https://svn.apache.org/r1633735 ]

        SOLR-6587: Correct exception thrown on bad collection configuration in SolrCloud mode


          People

          • Assignee:
            Tomás Fernández Löbbe
            Reporter:
            Tomás Fernández Löbbe
          • Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development