Uploaded image for project: 'Solr'
  1. Solr
  2. SOLR-6497

Solr 4.10 returning SolrDocument instances with empty map when dynamic fields are requested

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Critical
    • Resolution: Duplicate
    • Affects Version/s: 4.10
    • Fix Version/s: None
    • Component/s: clients - java
    • Labels:
    • Environment:

      Windows 7, JDK8u11

      Description

      I recently upgraded from Solr 4.9 to 4.10. At some point in the code I want to return the values for some dynamic fields. If I do this:

          SolrQuery query = new SolrQuery();
          query.addField("code");
          query.addField("name");
      

      it returns the right values in the fields code and name.

      If I do this:

          SolrQuery query = new SolrQuery();
          query.addField("code");
          query.addField("name");
          query.addField("*_prop");
      

      all the fields ,including code and name, are null.

        Issue Links

          Activity

          shalinmangar Shalin Shekhar Mangar added a comment -

          I think this may be a duplicate of SOLR-6501

          biliboc Constantin Mitocaru added a comment -

          Yes, it's true. The thing is SOLR-6501 did not exist when I created this.

          biliboc Constantin Mitocaru added a comment -

          Duplicate of SOLR-6501


            People

            • Assignee:
              Unassigned
              Reporter:
              biliboc Constantin Mitocaru
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development