Uploaded image for project: 'Solr'
  1. Solr
  2. SOLR-6400

SolrCloud tests are not properly testing session expiration.

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: SolrCloud
    • Labels:
      None

      Description

      We are using a test method from the ZK project to pause the connection for a length of time. A while back, I found that the pause time did not really matter. All that happens is that the connection is closed and the zk client creates a new one. So it just causes a dc event, but never reaches expiration.

        Activity

        thelabdude Timothy Potter added a comment -

        Great catch Mark! I feel bad because I noticed this too, assumed it was working as designed, and then just worked around it by calling expire directly on the session

        jira-bot ASF subversion and git services added a comment -

        Commit 1619612 from Mark Miller in branch 'dev/trunk'
        [ https://svn.apache.org/r1619612 ]

        SOLR-6400: SolrCloud tests are not properly testing session expiration.

        jira-bot ASF subversion and git services added a comment -

        Commit 1619613 from Mark Miller in branch 'dev/branches/branch_4x'
        [ https://svn.apache.org/r1619613 ]

        SOLR-6400: SolrCloud tests are not properly testing session expiration.

        andyetitmoves Ramkumar Aiyengar added a comment -

        I made a change with SOLR-6370 to override bits of the test zk server for watch reporting. We could possibly use those hooks to improbably expire connections once in a while. Would add a bit of chaosmonkeyness to all tests..

        ctargett Cassandra Targett added a comment -

        This looks like it's been fixed for a while. If I'm interpreting the commits wrong, please re-open.


          People

          • Assignee:
            markrmiller@gmail.com Mark Miller
            Reporter:
            markrmiller@gmail.com Mark Miller
          • Votes:
            0 Vote for this issue
            Watchers:
            4 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development