Uploaded image for project: 'Solr'
  1. Solr
  2. SOLR-6022

Rename getAnalyzer to getIndexAnalyzer

Agile BoardAttach filesAttach ScreenshotVotersWatch issueWatchersCreate sub-taskLinkCloneUpdate Comment AuthorReplace String in CommentUpdate Comment VisibilityDelete Comments
    XMLWordPrintableJSON

Details

    • Improvement
    • Status: Resolved
    • Major
    • Resolution: Fixed
    • None
    • 4.9, 6.0
    • None
    • None

    Description

      We have separate index/query analyzer chains, but the access methods for the analyzers do not match up with the names. This can lead to unknowingly using the wrong analyzer chain (as it did in SOLR-6017). We should do this renaming in trunk, and deprecate the old getAnalyzer function in 4x.

      Attachments

        1. SOLR-6022.patch
          37 kB
          Ryan Ernst
        2. SOLR-6022.branch_4x-deprecation.patch
          4 kB
          Ryan Ernst
        3. SOLR-6022.patch
          34 kB
          Ryan Ernst
        4. SOLR-6022.patch
          33 kB
          Ryan Ernst

        Activity

          This comment will be Viewable by All Users Viewable by All Users
          Cancel

          People

            rjernst Ryan Ernst
            rjernst Ryan Ernst
            Votes:
            0 Vote for this issue
            Watchers:
            5 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved:

              Slack

                Issue deployment