Solr
  1. Solr
  2. SOLR-5865

Provide a MiniSolrCloudCluster to enable easier testing

    Details

    • Type: Improvement Improvement
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 4.7, 6.0
    • Fix Version/s: 4.8, 6.0
    • Component/s: SolrCloud
    • Labels:
      None

      Description

      Today, the SolrCloud tests are based on the LuceneTestCase class hierarchy, which has a couple of issues around support for downstream projects:

      • It's difficult to test SolrCloud support in a downstream project that may have its own test framework. For example, some projects have support for different storage backends (e.g. Solr/ElasticSearch/HBase) and want tests against each of the different backends. This is difficult to do cleanly, because the Solr tests require derivation from LuceneTestCase, while the other don't
      • The LuceneTestCase class hierarchy is really designed for internal solr tests (e.g. it randomizes a lot of parameters to get test coverage, but a downstream project probably doesn't care about that). It's also quite complicated and dense, much more so than a downstream project would want.

      Given these reasons, it would be nice to provide a simple "MiniSolrCloudCluster", similar to how HDFS provides a MiniHdfsCluster or HBase provides a MiniHBaseCluster.

      1. SOLR-5865.patch
        15 kB
        Gregory Chanan
      2. SOLR-5865.patch
        15 kB
        Gregory Chanan
      3. SOLR-5865addendum.patch
        1 kB
        Gregory Chanan
      4. SOLR-5865addendum2.patch
        2 kB
        Gregory Chanan
      5. SOLR-5865wait.patch
        4 kB
        Gregory Chanan

        Activity

        Gregory Chanan added a comment -

        Here's a patch that implements a MiniSolrCloudCluster and a simple test exercising it. The test doesn't use the normal LuceneTestCase test class hierarchy, because that is one of the motivations for the MiniSolrCloudCluster: that downstream projects will want to use their own test framework.

        One limitation on the test currently is it does not start a MiniDFSCluster, as the code necessary for that lives in solr/core rather than the test framework. I'm not 100% sure why that is, but if no one has an objection I'll go ahead and make that change in a later patch.

        To demonstrate to myself that this is useful, I implemented one of the Apache Sentry tests using this test framework rather than AbstractFullDistribZkTestBase. See the current state of the test here: https://github.com/apache/incubator-sentry/blob/644e8be346a152e43fa435b9adbb47ce6b3e3e91/sentry-tests/sentry-tests-solr/src/test/java/org/apache/sentry/tests/e2e/solr/AbstractSolrSentryTestBase.java. This was pretty straightforward, with the exception of getting the MiniDFSCluster stuff correct, as mentioned above.

        Mark Miller added a comment -

        Looks great!

        + // We could upload the minimum set of files rather than the directory, but that requires keeping the list up to date
        + ZkController.uploadToZK(zkClient, new File(configDir), ZkController.CONFIGS_ZKNODE + "/" + configName);

        The main reason most of the cloud tests have gone with specifying which config files to put in zk was that uploading the entire directory of test configs was damn slow and then repeated for all cloud tests.

        A better solution at some point would be a new test config folder just for solrcloud. We already have a lot of configs, but we could probably merge some things into this - like the common solrconfig and schema that almost all cloud tests use anyway. If we kept it to one set, I think it would be an improvement for cloud tests.

        Gregory Chanan added a comment -

        Thanks for taking a look, Mark.

        I get that having all the tests upload the files is burdensome. I figured because this is just one test (and probably the only one outside of the test hierarchy, by design) that was preferable to maintaining a list in multiple places (the set of files for the hierarchy tests and this one). I like your solution of separating out the solrcloud configs best, though. I'll take a look at how feasible that is.

        Mark Miller added a comment -

        Yup, no worries - that can certainly be another issue.

        Gregory Chanan added a comment -

        I filed SOLR-5879 for the config directory idea.

        Gregory Chanan added a comment -

        Here's a version of the patch that uploads the individual config files to ZooKeeper.

        ASF subversion and git services added a comment -

        Commit 1579116 from Mark Miller in branch 'dev/trunk'
        [ https://svn.apache.org/r1579116 ]

        SOLR-5865: Provide a MiniSolrCloudCluster to enable easier testing.

        ASF subversion and git services added a comment -

        Commit 1579118 from Mark Miller in branch 'dev/branches/branch_4x'
        [ https://svn.apache.org/r1579118 ]

        SOLR-5865: Provide a MiniSolrCloudCluster to enable easier testing.

        Mark Miller added a comment -

        Fails the forbidden APIs check:
        [forbidden-apis] Forbidden method invocation: java.util.Random#<init>() [Use RandomizedRunner's random instead]
        [forbidden-apis] in org.apache.solr.cloud.TestMiniSolrCloudCluster (TestMiniSolrCloudCluster.java:67)

        ASF subversion and git services added a comment -

        Commit 1579135 from Mark Miller in branch 'dev/trunk'
        [ https://svn.apache.org/r1579135 ]

        SOLR-5865: Don't use random for now, un@Ignore test, clear static in afterClass.

        ASF subversion and git services added a comment -

        Commit 1579137 from Mark Miller in branch 'dev/branches/branch_4x'
        [ https://svn.apache.org/r1579137 ]

        SOLR-5865: Don't use random for now, un@Ignore test, clear static in afterClass.

        ASF subversion and git services added a comment -

        Commit 1579247 from Mark Miller in branch 'dev/trunk'
        [ https://svn.apache.org/r1579247 ]

        SOLR-5865: Ignore test for the moment.

        ASF subversion and git services added a comment -

        Commit 1579248 from Mark Miller in branch 'dev/branches/branch_4x'
        [ https://svn.apache.org/r1579248 ]

        SOLR-5865: Ignore test for the moment.

        Gregory Chanan added a comment -

        Did the test fail? Need me to look at anything, Mark?

        Gregory Chanan added a comment -

        I think the issue is that the System properties are not cleared and can have effects on later tests. Here's a version that clears them...I was able to run all the unit tests successfully with this applied. Mind giving this a spin, Mark?

        Mark Miller added a comment -

        Thanks Greg - I think the main issue is the zkHost sys prop - I've added the following as well:

        System.clearProperty("solr.solrxml.location");
        System.clearProperty("zkHost");

        That's one complication of avoiding the test framework - normally there are checks applied for this type of thing and the test will fail if you violate it and tell which sys props were not reset or which threads were not stopped, etc.

        Alan Woodward added a comment -

        Can you just use SystemPropertiesRestoreRule?

        Mark Miller added a comment -

        I think the main issue is the zkHost sys pro

        Hmm - that is not it either - the MiniSolrCloudCluster will clear those on shutdown as well. I'm still seeing some leakage somehow though.

        Can you just use SystemPropertiesRestoreRule?

        Let me give a try.

        ASF subversion and git services added a comment -

        Commit 1579679 from Mark Miller in branch 'dev/trunk'
        [ https://svn.apache.org/r1579679 ]

        SOLR-5865: Un@Ignore test again.

        ASF subversion and git services added a comment -

        Commit 1579682 from Mark Miller in branch 'dev/branches/branch_4x'
        [ https://svn.apache.org/r1579682 ]

        SOLR-5865: Un@Ignore test again.

        Mark Miller added a comment -

        Hmm - nope, I can still see something. It's just becoming rarer. I think this one is from threads leaking past the end of the test. The test framework has a linger for this and attempted interrupts (linger has shown to be especially important for zk tests, which has threads that can seem to linger for a while after shutdown).

        Gregory Chanan added a comment -

        Hmm, at this point may make more sense to not try to get the test to work outside of the test hierarchy completely. We could try to recreate the minimum set of what we need there (SystemPropertiesRestoreRules and ThreadLeakScopes) but that may change in the test hierarchy itself, requiring just this test to update. The important thing, I think, is that we don't require the complete SolrCloud test hierarchy, e.g. AbstractFullDistribZkTestBase and the like.

        The question then, is whether we rely on LuceneTestCase or SolrTestCaseJ4. LuceneTestCase is arguably better, because we know we don't rely on anything solr-specific for the test, although the downside is we may have to update it to keep in sync with the SolrTestCaseJ4. I don't have a strong preference either way.

        I messed around with that a little bit and I have a patch that seems to work with just LuceneTestCase – I had to import the a couple of rules from SolrTestCaseJ4, but not much. I haven't run the full suite though, so I'm not 100% sure it's kosher.

        Gregory Chanan added a comment -

        Here's a patch that depends on LuceneTestCase. As I mentioned above, I haven't run the whole suite with this.

        ASF subversion and git services added a comment -

        Commit 1579951 from Mark Miller in branch 'dev/trunk'
        [ https://svn.apache.org/r1579951 ]

        SOLR-5865: Testing improvements.

        ASF subversion and git services added a comment -

        Commit 1579952 from Mark Miller in branch 'dev/branches/branch_4x'
        [ https://svn.apache.org/r1579952 ]

        SOLR-5865: Testing improvements.

        Mark Miller added a comment -

        Thanks Greg!

        Gregory Chanan added a comment -

        Thanks for handling this Mark.

        I haven't seen this fail on trunk, but when backporting it to solr 4.4 I do see some failures. They seem related to creating a collection and acting on it immediately; some of the existing tests use "waitForRecoveriesToFinish" before proceeding in this situation. I'm unclear if this is necessary or not but at least with solr 4.4 it seems to alleviate the issues. I'll upload a patch that adds that to the test. As an aside, is there a JIRA or documentation that address the waitForRecoveriesToFinish issue?

        Mark Miller added a comment -

        I haven't seen this fail on trunk

        I have seen it fail a least a handful of times on the public jenkins cluster, but not often. It should be in the email archives. It fails more consistently on trunk on my private jenkins server. So it's def an issue in both cases (4.4 code and trunk).

        It's not unexpected that you need waitForRecoveriesToFinish to ensure the collection is useable - all the tests have been using it for some time - but it's also not very desirable. To my knowledge there is no JIRA issue for improving this yet.

        Ideally, when a collection call returns, the collection is useable at that time.

        Gregory Chanan added a comment -

        Great, thanks for the data Mark.

        If I get some time in the near future I'll investigate/file a jira around the waitForRecoveriesToFinish issue.

        Uwe Schindler added a comment -

        Close issue after release of 4.8.0

        ASF GitHub Bot added a comment -

        GitHub user softwaredoug opened a pull request:

        https://github.com/apache/camel/pull/218

        Solr Component: Solr Cloud Support, HTTPS support, many many test updates to support.

        New SolrCloud producer. Can be used with

        solrCloud://localhost:8983?zkHost=localhost:8123/solr&collection=collection1

        Solr producer can also be used with HTTPS via solrs:

        solrs://localhost:8983

        Most of the changes in this patch have to do with test updates to support these changes. The test updates run all the existing camel-solr tests against all three possible Solr endpoints: normal HTTP Solr server, an HTTPS Solr Server, and an embedded Solr Cloud cluster. The latter utilizes Solr 4.8's [MiniSolrCloudCluster](https://issues.apache.org/jira/browse/SOLR-5865) support to create an embedded Solr Cloud cluster for testing.

        Additional updates have to do with reorganizing and updating the solr configurations to support Solr 4 and updates required for Solr Cloud support.

        Let me know if you have any questions!

        You can merge this pull request into a Git repository by running:

        $ git pull https://github.com/o19s/camel master

        Alternatively you can review and apply these changes as the patch at:

        https://github.com/apache/camel/pull/218.patch

        To close this pull request, make a commit to your master/trunk branch
        with (at least) the following in the commit message:

        This closes #218


        commit 54fb275c7fa8b3ff7ef308ece9081b0b780abc38
        Author: Doug Turnbull <softwaredoug@gmail.com>
        Date: 2014-04-26T18:08:35Z

        Initial commit

        commit 2d0cb27e525e9f9e0a11c9bbe2c23c0472187d62
        Author: Doug Turnbull <dturnbull@o19s.com>
        Date: 2014-04-26T18:24:36Z

        Merge branch 'master' of https://github.com/o19s/camel

        Conflicts:
        .gitignore

        commit 31ec7e5b1dab20bc38b32ae6c70cb36e0723e850
        Author: Doug Turnbull <dturnbull@o19s.com>
        Date: 2014-04-28T20:49:04Z

        Add https server to tests

        commit 2485a7f0510ef69b06e3abacd205926ce5d02bb8
        Author: Doug Turnbull <dturnbull@o19s.com>
        Date: 2014-04-29T01:41:28Z

        Allow loose SSL client validation for testing

        commit e7f4ada8e54bd97d27cfdf58d251e0b7760c7edb
        Author: Doug Turnbull <dturnbull@o19s.com>
        Date: 2014-04-29T02:19:04Z

        Setup https solrj client correctly

        commit 19999722e93f66d0f71efe8b88d76cd32f0f8f4c
        Author: Doug Turnbull <dturnbull@o19s.com>
        Date: 2014-04-29T17:44:29Z

        Try to get solrcloud test fixtures

        commit 1a0d6fa00beeb5366cec8f2a24bb2e0b5e2861be
        Author: Doug Turnbull <dturnbull@o19s.com>
        Date: 2014-05-02T16:04:59Z

        Migrate to Solr 4.8. Fix test solr config to reflect updates.

        commit b0c1a0ea6996c3cbd86e3a39fb18d9c1cadf430e
        Author: Doug Turnbull <dturnbull@o19s.com>
        Date: 2014-06-17T01:03:49Z

        Get SolrCloudFixture working

        commit eeb434e5062881ad1d48705b6e3098bd6bbbdbf2
        Author: Doug Turnbull <dturnbull@o19s.com>
        Date: 2014-06-17T02:06:09Z

        Different data dir per solr runner

        commit a41a8583fa20353a30d4a1ffebfcfe130e577a58
        Author: Scott Stults <sstults@o19s.com>
        Date: 2014-06-27T05:17:50Z

        During the CSV file test the content type was assigned as "application/octet-stream". Solr needs this to be "text/csv" or similar.

        commit 320a0232bdbed8495b03c61acd2859a4b3243c42
        Author: Scott Stults <sstults@o19s.com>
        Date: 2014-06-27T05:50:15Z

        Removing unused dependency

        commit 1ad4708f81d4d71c4724900cf077bd3c8a63661b
        Author: Doug Turnbull <dturnbull@o19s.com>
        Date: 2014-07-14T21:17:16Z

        Cloud tests work (but they fail)

        commit e01347c07a26a7a5728f7809529f092216e22a7a
        Author: Doug Turnbull <dturnbull@o19s.com>
        Date: 2014-07-14T21:25:11Z

        Get zkHost correctly when constructing test endpoint (a test passes!)

        commit 684d6051c48611418cc879114bbb87ae06220ada
        Author: Doug Turnbull <dturnbull@o19s.com>
        Date: 2014-07-14T21:52:01Z

        Merge branch 'master' of github.com:o19s/camel

        Conflicts:
        parent/pom.xml

        commit 08a1654469faa4a9eeca163072c4653f7d681278
        Author: Doug Turnbull <dturnbull@o19s.com>
        Date: 2014-07-14T21:58:55Z

        Added solrCloud SPI, all tests pass.


        ASF GitHub Bot added a comment -

        Github user asfgit closed the pull request at:

        https://github.com/apache/camel/pull/218


          People

          • Assignee:
            Mark Miller
            Reporter:
            Gregory Chanan
          • Votes:
            0 Vote for this issue
            Watchers:
            5 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development