Solr
  1. Solr
  2. SOLR-5588

PeerSync doesn't count all connect failures as success.

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 4.6.1, 4.7, 5.0
    • Component/s: SolrCloud
    • Labels:
      None

      Activity

      Mark Miller added a comment -

      In the following case, the root exception is a SocketTimeoutException and the Connection exception is higher in the stack.

         [junit4]   2> 284374 T1230 C272 P16917 oasu.PeerSync.handleResponse WARN PeerSync: core=collection1 url=http://127.0.0.1:16917/z  exception talking to http://127.0.0.1:24788/z/collection1/, failed org.apache.solr.client.solrj.SolrServerException: IOException occured when talking to server at: http://127.0.0.1:24788/z/collection1
         [junit4]   2> 	at org.apache.solr.client.solrj.impl.HttpSolrServer.request(HttpSolrServer.java:507)
         [junit4]   2> 	at org.apache.solr.client.solrj.impl.HttpSolrServer.request(HttpSolrServer.java:199)
         [junit4]   2> 	at org.apache.solr.handler.component.HttpShardHandler$1.call(HttpShardHandler.java:156)
         [junit4]   2> 	at org.apache.solr.handler.component.HttpShardHandler$1.call(HttpShardHandler.java:118)
         [junit4]   2> 	at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:334)
         [junit4]   2> 	at java.util.concurrent.FutureTask.run(FutureTask.java:166)
         [junit4]   2> 	at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:471)
         [junit4]   2> 	at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:334)
         [junit4]   2> 	at java.util.concurrent.FutureTask.run(FutureTask.java:166)
         [junit4]   2> 	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)
         [junit4]   2> 	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
         [junit4]   2> 	at java.lang.Thread.run(Thread.java:724)
         [junit4]   2> Caused by: org.apache.http.conn.ConnectTimeoutException: Connect to 127.0.0.1:24788 timed out
         [junit4]   2> 	at org.apache.http.conn.scheme.PlainSocketFactory.connectSocket(PlainSocketFactory.java:129)
         [junit4]   2> 	at org.apache.http.impl.conn.DefaultClientConnectionOperator.openConnection(DefaultClientConnectionOperator.java:180)
         [junit4]   2> 	at org.apache.http.impl.conn.ManagedClientConnectionImpl.open(ManagedClientConnectionImpl.java:294)
         [junit4]   2> 	at org.apache.http.impl.client.DefaultRequestDirector.tryConnect(DefaultRequestDirector.java:643)
         [junit4]   2> 	at org.apache.http.impl.client.DefaultRequestDirector.execute(DefaultRequestDirector.java:479)
         [junit4]   2> 	at org.apache.http.impl.client.AbstractHttpClient.execute(AbstractHttpClient.java:906)
         [junit4]   2> 	at org.apache.http.impl.client.AbstractHttpClient.execute(AbstractHttpClient.java:805)
         [junit4]   2> 	at org.apache.http.impl.client.AbstractHttpClient.execute(AbstractHttpClient.java:784)
         [junit4]   2> 	at org.apache.solr.client.solrj.impl.HttpSolrServer.request(HttpSolrServer.java:395)
         [junit4]   2> 	... 11 more
         [junit4]   2> Caused by: java.net.SocketTimeoutException: connect timed out
         [junit4]   2> 	at java.net.PlainSocketImpl.socketConnect(Native Method)
         [junit4]   2> 	at java.net.AbstractPlainSocketImpl.doConnect(AbstractPlainSocketImpl.java:339)
         [junit4]   2> 	at java.net.AbstractPlainSocketImpl.connectToAddress(AbstractPlainSocketImpl.java:200)
         [junit4]   2> 	at java.net.AbstractPlainSocketImpl.connect(AbstractPlainSocketImpl.java:182)
         [junit4]   2> 	at java.net.SocksSocketImpl.connect(SocksSocketImpl.java:392)
         [junit4]   2> 	at java.net.Socket.connect(Socket.java:579)
         [junit4]   2> 	at org.apache.http.conn.scheme.PlainSocketFactory.connectSocket(PlainSocketFactory.java:127)
         [junit4]   2> 	... 19 more
      
      ASF subversion and git services added a comment -

      Commit 1554129 from Mark Miller in branch 'dev/trunk'
      [ https://svn.apache.org/r1554129 ]

      SOLR-5588: PeerSync doesn't count all connect failures as success.

      ASF subversion and git services added a comment -

      Commit 1554130 from Mark Miller in branch 'dev/branches/branch_4x'
      [ https://svn.apache.org/r1554130 ]

      SOLR-5588: PeerSync doesn't count all connect failures as success.

      ASF subversion and git services added a comment -

      Commit 1554131 from Mark Miller in branch 'dev/branches/lucene_solr_4_6'
      [ https://svn.apache.org/r1554131 ]

      SOLR-5588: PeerSync doesn't count all connect failures as success.


        People

        • Assignee:
          Mark Miller
          Reporter:
          Mark Miller
        • Votes:
          0 Vote for this issue
          Watchers:
          2 Start watching this issue

          Dates

          • Created:
            Updated:
            Resolved:

            Development