Solr
  1. Solr
  2. SOLR-5438

DebugComponent throws NPE when used with grouping

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 4.7, 6.0
    • Component/s: None
    • Labels:
      None

      Description

      To Reproduce:
      start trunk example
      Run query: http://localhost:8983/solr/select?q=test&debug=true&group=true&group.field=inStock&distrib=true&shards=localhost:8983/solr,localhost:8983/solr

      DebugComponent throws a NPE like:

      83841 [qtp1070887245-16] ERROR org.apache.solr.servlet.SolrDispatchFilter  – null:java.lang.NullPointerException
      at org.apache.solr.handler.component.DebugComponent.process(DebugComponent.java:66)
      at org.apache.solr.handler.component.SearchHandler.handleRequestBody(SearchHandler.java:216)
      at org.apache.solr.handler.RequestHandlerBase.handleRequest(RequestHandlerBase.java:135)
      at org.apache.solr.core.SolrCore.execute(SolrCore.java:1859)
      at org.apache.solr.servlet.SolrDispatchFilter.execute(SolrDispatchFilter.java:703)
      at org.apache.solr.servlet.SolrDispatchFilter.doFilter(SolrDispatchFilter.java:406)
      at org.apache.solr.servlet.SolrDispatchFilter.doFilter(SolrDispatchFilter.java:195)
      at org.eclipse.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1419)
      at org.eclipse.jetty.servlet.ServletHandler.doHandle(ServletHandler.java:455)
      at org.eclipse.jetty.server.handler.ScopedHandler.handle(ScopedHandler.java:137)
      at org.eclipse.jetty.security.SecurityHandler.handle(SecurityHandler.java:557)
      at org.eclipse.jetty.server.session.SessionHandler.doHandle(SessionHandler.java:231)
      at org.eclipse.jetty.server.handler.ContextHandler.doHandle(ContextHandler.java:1075)
      at org.eclipse.jetty.servlet.ServletHandler.doScope(ServletHandler.java:384)
      at org.eclipse.jetty.server.session.SessionHandler.doScope(SessionHandler.java:193)
      at org.eclipse.jetty.server.handler.ContextHandler.doScope(ContextHandler.java:1009)
      at org.eclipse.jetty.server.handler.ScopedHandler.handle(ScopedHandler.java:135)
      at org.eclipse.jetty.server.handler.ContextHandlerCollection.handle(ContextHandlerCollection.java:255)
      at org.eclipse.jetty.server.handler.HandlerCollection.handle(HandlerCollection.java:154)
      at org.eclipse.jetty.server.handler.HandlerWrapper.handle(HandlerWrapper.java:116)
      at org.eclipse.jetty.server.Server.handle(Server.java:368)
      at org.eclipse.jetty.server.AbstractHttpConnection.handleRequest(AbstractHttpConnection.java:489)
      at org.eclipse.jetty.server.BlockingHttpConnection.handleRequest(BlockingHttpConnection.java:53)
      at org.eclipse.jetty.server.AbstractHttpConnection.content(AbstractHttpConnection.java:953)
      at org.eclipse.jetty.server.AbstractHttpConnection$RequestHandler.content(AbstractHttpConnection.java:1014)
      at org.eclipse.jetty.http.HttpParser.parseNext(HttpParser.java:861)
      at org.eclipse.jetty.http.HttpParser.parseAvailable(HttpParser.java:240)
      at org.eclipse.jetty.server.BlockingHttpConnection.handle(BlockingHttpConnection.java:72)
      at org.eclipse.jetty.server.bio.SocketConnector$ConnectorEndPoint.run(SocketConnector.java:264)
      at org.eclipse.jetty.util.thread.QueuedThreadPool.runJob(QueuedThreadPool.java:608)
      at org.eclipse.jetty.util.thread.QueuedThreadPool$3.run(QueuedThreadPool.java:543)
      at java.lang.Thread.run(Thread.java:722)
      

      Seems like some internal requests when using grouping don't populate ResponseBuilder.results.

      1. SOLR-5438.patch
        6 kB
        Shalin Shekhar Mangar
      2. SOLR-5438.patch
        5 kB
        Tomás Fernández Löbbe

        Issue Links

          Activity

          Tomás Fernández Löbbe added a comment -

          The problem seems to be when getting the doc explain. This can be done in the last grouping phase.

          Shalin Shekhar Mangar added a comment -

          Patch updated to trunk.

          ASF subversion and git services added a comment -

          Commit 1541849 from shalin@apache.org in branch 'dev/trunk'
          [ https://svn.apache.org/r1541849 ]

          SOLR-5438: DebugComponent throws NPE when used with grouping

          ASF subversion and git services added a comment -

          Commit 1541853 from shalin@apache.org in branch 'dev/branches/branch_4x'
          [ https://svn.apache.org/r1541853 ]

          SOLR-5438: DebugComponent throws NPE when used with grouping

          Shalin Shekhar Mangar added a comment -

          This is fixed. Thanks Tomás!


            People

            • Assignee:
              Shalin Shekhar Mangar
              Reporter:
              Tomás Fernández Löbbe
            • Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development