Uploaded image for project: 'Solr'
  1. Solr
  2. SOLR-5380

Using cloudSolrServer.setDefaultCollection(collectionId) does not work as intended for an alias spanning more than 1 collection.

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 4.6, 6.0
    • Component/s: SolrCloud
    • Labels:
      None

      Activity

      markrmiller@gmail.com Mark Miller added a comment - - edited
      markrmiller@gmail.com Mark Miller added a comment -

      The problem was that no collection parameter was set for the request in the case of using the default collection. Because of this, the alias used as the default collection was no propagated.

      Because it's difficult to update the params for the request, I chose to change how we create urls in the default collection case - rather than using base_url + core_name, I use base_url + default collection. SolrDispatchFilter then handles the rest.

      jira-bot ASF subversion and git services added a comment -

      Commit 1535076 from Mark Miller in branch 'dev/trunk'
      [ https://svn.apache.org/r1535076 ]

      SOLR-5380: Using cloudSolrServer.setDefaultCollection(collectionId) does not work as intended for an alias spanning more than 1 collection.

      jira-bot ASF subversion and git services added a comment -

      Commit 1535077 from Mark Miller in branch 'dev/branches/branch_4x'
      [ https://svn.apache.org/r1535077 ]

      SOLR-5380: Using cloudSolrServer.setDefaultCollection(collectionId) does not work as intended for an alias spanning more than 1 collection.

      thetaphi Uwe Schindler added a comment -

      Move issue to Solr 4.9.

      anshumg Anshum Gupta added a comment -

      Mark Miller Is this already fixed?


        People

        • Assignee:
          markrmiller@gmail.com Mark Miller
          Reporter:
          markrmiller@gmail.com Mark Miller
        • Votes:
          0 Vote for this issue
          Watchers:
          4 Start watching this issue

          Dates

          • Created:
            Updated:
            Resolved:

            Development