Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 4.4, 4.5
    • Fix Version/s: 4.7, 6.0
    • Labels:
      None
    • Environment:

      MS Windows 2008 Release 2

      Description

      When a WMZ file is sent to solr on resource /update/extract, the following exception is thrown by solr:

      ERROR - 2013-10-17 18:13:48.902; org.apache.solr.common.SolrException; null:java.lang.RuntimeException: java.lang.NoSuchMethodError: org.apache.commons.compress.compressors.CompressorStreamFactory.setDecompressConcatenated(Z)V
      at org.apache.solr.servlet.SolrDispatchFilter.sendError(SolrDispatchFilter.java:673)
      at org.apache.solr.servlet.SolrDispatchFilter.doFilter(SolrDispatchFilter.java:383)
      at org.apache.solr.servlet.SolrDispatchFilter.doFilter(SolrDispatchFilter.java:158)
      at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:243)
      at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:210)
      at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:222)
      at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:123)
      at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:171)
      at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:99)
      at org.apache.catalina.valves.AccessLogValve.invoke(AccessLogValve.java:953)
      at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:118)
      at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:408)
      at org.apache.coyote.http11.AbstractHttp11Processor.process(AbstractHttp11Processor.java:1023)
      at org.apache.coyote.AbstractProtocol$AbstractConnectionHandler.process(AbstractProtocol.java:589)
      at org.apache.tomcat.util.net.AprEndpoint$SocketProcessor.run(AprEndpoint.java:1852)
      at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
      at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
      at java.lang.Thread.run(Unknown Source)
      Caused by: java.lang.NoSuchMethodError: org.apache.commons.compress.compressors.CompressorStreamFactory.setDecompressConcatenated(Z)V
      at org.apache.tika.parser.pkg.CompressorParser.parse(CompressorParser.java:102)
      at org.apache.tika.parser.CompositeParser.parse(CompositeParser.java:242)
      at org.apache.tika.parser.CompositeParser.parse(CompositeParser.java:242)
      at org.apache.tika.parser.AutoDetectParser.parse(AutoDetectParser.java:120)
      at org.apache.solr.handler.extraction.ExtractingDocumentLoader.load(ExtractingDocumentLoader.java:219)
      at org.apache.solr.handler.ContentStreamHandlerBase.handleRequestBody(ContentStreamHandlerBase.java:74)
      at org.apache.solr.handler.RequestHandlerBase.handleRequest(RequestHandlerBase.java:135)
      at org.apache.solr.core.RequestHandlers$LazyRequestHandlerWrapper.handleRequest(RequestHandlers.java:241)
      at org.apache.solr.core.SolrCore.execute(SolrCore.java:1904)
      at org.apache.solr.servlet.SolrDispatchFilter.execute(SolrDispatchFilter.java:659)
      at org.apache.solr.servlet.SolrDispatchFilter.doFilter(SolrDispatchFilter.java:362)
      ... 16 more

      According to Koji Sekiguchi, Tika 1.4, the version bundled with solr, should use common-compress-1.5, but version 1.4.1 is present in solr/contrib/extraction/lib/ directory.

      During our testing, the ignoreTikaException flag was set to true.

      1. SOLR-3565.patch
        0.5 kB
        Jan Høydahl
      2. SOLR-5365.patch
        4 kB
        Hoss Man

        Issue Links

          Activity

          Koji Sekiguchi added a comment -

          Input from Guido Medina in solr ML:

          http://mail-archives.apache.org/mod_mbox/lucene-solr-user/201310.mbox/%3C52612E0F.2080302%40temetra.com%3E

          Dont, commons compress 1.5 is broken, either use 1.4.1 or later. Our app
          stopped compressing properly for a maven update.

          Guido.

          Patrick Uhlmann added a comment -

          It just tested it with version SOLR 4.6.1. Same problem. In order to make it work you just need to replace commons-compress-1.4.1 in the folder contrib/extract with commons-compress-1.7. Neither version 1.4.1 nor 1.5 have the method setDecompressConcatenated in the class CompressorStreamFactory.

          Jan Høydahl added a comment -

          Naïve patch attached. Also needed is better test coverage in ExtractingRequestHandlerTest.

          For the future, is there some way we could compare the versions between the transitive dependencies of Tika and what we use in our ivy file, only for those libraries that we already declare ourselves? Fail the precommit task if we use a lower version.

          Hoss Man added a comment -

          update patch...

          • fixes the SHA1 file for the upgraded commons-compress
          • adds a test (using a tiny compressed file) that fails with the described error w/o this patch.

          Sanity checking that this upgrade doesn't break any other tests, and assuming no problems i'll commit & backport.

          Hoss Man added a comment -

          filed LUCENE-5442 to see about better detection for this general class of transitive dependency problems

          ASF subversion and git services added a comment -

          Commit 1567824 from hossman@apache.org in branch 'dev/trunk'
          [ https://svn.apache.org/r1567824 ]

          SOLR-5365: Fix bug with compressed files in ExtractingRequestHandler by upgrading commons-compress to 1.7

          ASF subversion and git services added a comment -

          Commit 1567825 from hossman@apache.org in branch 'dev/branches/branch_4x'
          [ https://svn.apache.org/r1567825 ]

          SOLR-5365: Fix bug with compressed files in ExtractingRequestHandler by upgrading commons-compress to 1.7 (merge r1567824)

          Steve Rowe added a comment -

          Chris Hostetter (Unused), looks like this can be resolved (and closed) with fix version 4.7?

          Hoss Man added a comment -

          yep .. oversight


            People

            • Assignee:
              Hoss Man
              Reporter:
              Roland Everaert
            • Votes:
              0 Vote for this issue
              Watchers:
              5 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development