Solr
  1. Solr
  2. SOLR-4854

Query elevation [elevated] field always false with java binary communication

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 4.3
    • Fix Version/s: 5.4, 6.0
    • Component/s: clients - java
    • Labels:
      None
    • Environment:

      tomcat 6.0.33, java 1.6.0_26_x64, solrj 4.3

      Description

      With XMLResponseParser there is no problem, but with default BinaryResponseWriter [elevated] is always false.

      1. SOLR-4854.patch
        5 kB
        Shalin Shekhar Mangar
      2. SOLR-4854.patch
        0.6 kB
        Ray

        Activity

        Ray added a comment -

        This issues was still there, any plan to fix this?

        Ray added a comment -

        Upload patch, it works in our env

        Shalin Shekhar Mangar added a comment -

        Thanks Ray, can you add a test? Or give some steps for us to reproduce the problem?

        Gopal Patwa added a comment -

        Thanks Shalin, we will add test and steps reproduce soon

        Ray added a comment -

        Here is the test steps:
        1. enable QueryElevationComponent in solr server, please refer to wiki https://cwiki.apache.org/confluence/display/solr/The+Query+Elevation+Component
        2. call the solr with following parameters (I am using id as uniqueKey in my schema):
        q=foo&fl=id,[elevated]&enableElevation=true&forceElevation=true&elevateIds=<document_id>&wt=javabin&version=2
        make sure the document of <document_id> existed in your index.
        check the response to see if [elevated] value is true for document with id <document_id>

        We also need to verify another case with elevate.xml defined, instead of passing elevateIds in API.

        Let me know if you need more information.

        Shalin Shekhar Mangar added a comment -

        I added a test for this but I am not able to reproduce the problem on trunk. The original bug report was on 4.3. Which version of Solr are you using? Can you see the patch and let me know what I am doing wrong?

        Ray added a comment - - edited

        I am using solr with version 5.2.1.
        I reviewed your test cases and it looks good to me.
        Also I verified in version 5.3.1 and the issue was not there any more.
        I think we can close this JIRA now.

        ASF subversion and git services added a comment -

        Commit 1710667 from shalin@apache.org in branch 'dev/trunk'
        [ https://svn.apache.org/r1710667 ]

        SOLR-4854: Add a test to assert that [elevated] DocTransfer works correctly with javabin response format

        ASF subversion and git services added a comment -

        Commit 1710668 from shalin@apache.org in branch 'dev/branches/branch_5x'
        [ https://svn.apache.org/r1710668 ]

        SOLR-4854: Add a test to assert that [elevated] DocTransfer works correctly with javabin response format

        Shalin Shekhar Mangar added a comment -

        Thanks Ray. Even though this feature works fine in 5.3.1, I've committed the test anyway so that any future regressions can be caught easily. I'm marking this issue as fixed.


          People

          • Assignee:
            Shalin Shekhar Mangar
            Reporter:
            Istvan Hegedus
          • Votes:
            1 Vote for this issue
            Watchers:
            5 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development