Solr
  1. Solr
  2. SOLR-456

Ability to choose another analyzer for field

    Details

    • Type: Wish Wish
    • Status: Closed
    • Priority: Major Major
    • Resolution: Cannot Reproduce
    • Affects Version/s: 1.3
    • Fix Version/s: None
    • Component/s: highlighter
    • Labels:
      None

      Description

      To add new search options for example add case-sensitivity and not case-sensitivity search
      we need to index same field twice

      for example create field with 2 search options
      We should create 3 fields
      1. case-sensitive <cs_text> index only field
      not case-sensitive <ncs_text> index only field
      and storage only field <text>

      So to properly highlight search by index we should use analyzer from another field (we send hl.fl =text but search by cs_text or ncs_text)

      It's possible to add parameter to per field override highlighter analyzer?

      ie I want to send parameter
      f.<fieldName>.hl.fieldOverride=<anotherFieldName>

      or for example above:
      f.text.hl.fieldOverride=ncs_text

        Issue Links

          Activity

          Sergey Dryganets added a comment -

          There are patch to add such ability

          PS: It's just to show that it's easy to realize (I'm not perform any refactoring to minimize changes)

          Hoss Man added a comment -

          This seems like a specific manifestation of the larger issue of "field aliasing"

          brainstorming here...
          http://wiki.apache.org/solr/FieldAliasesAndGlobsInParams

          Erick Erickson added a comment -

          2013 Old JIRA cleanup

          Alexandre Rafalovitch added a comment -

          This seems to be a very-old request for highlighting an alternative field (not sure I understood exact requirements).

          But we now have hl.highlightAlternate, hl.alternateField, and hl.fl. It seems that one of these should fulfill the requirements.

          Is there anything else that needs to be done here?


            People

            • Assignee:
              Unassigned
              Reporter:
              Sergey Dryganets
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development