Solr
  1. Solr
  2. SOLR-4187

CachingDirectoryFactory NPE on release

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 5.0
    • Fix Version/s: 4.1, 5.0
    • Component/s: None
    • Labels:
      None
    • Environment:

      5.0.0.2012.12.14.10.53.04

      Description

      Likely related to SOLR-4171 and/or SOLR-3911. This occurs only on today's check out and not on all nodes just like my comment on SOLR-2529. The stack trace is only part the trace for opening a new searcher. The problem does not disappear after restarting the node.

      2012-12-14 10:34:17,771 INFO [solr.core.SolrCore] - [http-8080-exec-4] - : [shard_f] webapp=/solr path=/admin/ping params={} status=500 QTime=4 
      2012-12-14 10:34:17,771 ERROR [solr.servlet.SolrDispatchFilter] - [http-8080-exec-4] - : null:org.apache.solr.common.SolrException: Ping query caused exception: Error opening new searcher
              at org.apache.solr.handler.PingRequestHandler.handlePing(PingRequestHandler.java:262)
              at org.apache.solr.handler.PingRequestHandler.handleRequestBody(PingRequestHandler.java:210)
              at org.apache.solr.handler.RequestHandlerBase.handleRequest(RequestHandlerBase.java:146)
              at org.apache.solr.core.SolrCore.execute(SolrCore.java:1818)
              at org.apache.solr.servlet.SolrDispatchFilter.execute(SolrDispatchFilter.java:479)
              at org.apache.solr.servlet.SolrDispatchFilter.doFilter(SolrDispatchFilter.java:279)
              at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:235)
              at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
              at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:233)
              at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:191)
              at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:127)
              at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:102)
              at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:109)
              at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:293)
              at org.apache.coyote.http11.Http11NioProcessor.process(Http11NioProcessor.java:889)
              at org.apache.coyote.http11.Http11NioProtocol$Http11ConnectionHandler.process(Http11NioProtocol.java:744)
              at org.apache.tomcat.util.net.NioEndpoint$SocketProcessor.run(NioEndpoint.java:2274)
              at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886)
              at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908)
              at java.lang.Thread.run(Thread.java:662)
      Caused by: org.apache.solr.common.SolrException: Error opening new searcher
              at org.apache.solr.core.SolrCore.openNewSearcher(SolrCore.java:1425)
              at org.apache.solr.core.SolrCore.getSearcher(SolrCore.java:1537)
              at org.apache.solr.core.SolrCore.getSearcher(SolrCore.java:1314)
              at org.apache.solr.core.SolrCore.getSearcher(SolrCore.java:1249)
              at org.apache.solr.request.SolrQueryRequestBase.getSearcher(SolrQueryRequestBase.java:94)
              at org.apache.solr.handler.component.QueryComponent.process(QueryComponent.java:213)
              at org.apache.solr.handler.component.SearchHandler.handleRequestBody(SearchHandler.java:208)
              at org.apache.solr.handler.RequestHandlerBase.handleRequest(RequestHandlerBase.java:146)
              at org.apache.solr.core.SolrCore.execute(SolrCore.java:1818)
              at org.apache.solr.handler.PingRequestHandler.handlePing(PingRequestHandler.java:253)
              ... 19 more
      Caused by: java.lang.NullPointerException
              at org.apache.solr.core.CachingDirectoryFactory.release(CachingDirectoryFactory.java:333)
              at org.apache.solr.core.SolrCore.getNewIndexDir(SolrCore.java:263)
              at org.apache.solr.core.SolrCore.openNewSearcher(SolrCore.java:1336)
              ... 28 more
      
      2012-12-14 10:34:17,772 INFO [solr.core.SolrCore] - [http-8080-exec-4] - : [shard_f]  CLOSING SolrCore org.apache.solr.core.SolrCore@5965e55e
      2012-12-14 10:34:17,772 INFO [solr.update.UpdateHandler] - [http-8080-exec-4] - : closing DirectUpdateHandler2{commits=0,autocommit maxTime=120000ms,autocommits=0,soft autocommit maxTime=10000ms,soft autocommits=0,optimizes=0,rollbacks=0,expungeDeletes=0,docsPending=0,adds=0,deletesById=0,deletesByQuery=0,errors=0,cumulative_adds=0,cumulative_deletesById=0,cumulative_deletesByQuery=0,cumulative_errors=0}
      2012-12-14 10:34:17,772 INFO [solr.core.SolrCore] - [http-8080-exec-4] - : [openindex_f] Closing main searcher on request.
      

        Issue Links

          Activity

          Mark Miller added a comment -

          Interesting - I'll add a null check - I'm surprised though - though should be an exception above that or it seems difficult for this to happen.

          Commit Tag Bot added a comment -

          [trunk commit] Mark Robert Miller
          http://svn.apache.org/viewvc?view=revision&revision=1421914

          SOLR-4187: NPE on Directory release

          Commit Tag Bot added a comment -

          [branch_4x commit] Mark Robert Miller
          http://svn.apache.org/viewvc?view=revision&revision=1421920

          SOLR-4187: NPE on Directory release

          Markus Jelsma added a comment -

          Great work! This seems to be resolved now.


            People

            • Assignee:
              Mark Miller
              Reporter:
              Markus Jelsma
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development