Solr
  1. Solr
  2. SOLR-4106

Javac/ ivy path warnings with morfologik

    Details

    • Type: Task Task
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 4.1, 6.0
    • Component/s: None
    • Labels:
      None

      Description

      Does not break the build but brings javac warnings, as pointed out by rmuir:

      [javac] warning: [path] bad path element "~/.ivy2/cache/org.carrot2/morfologik-polish/jars/morfologik-stemming-1.5.3.jar": no such file or directory
         [javac] warning: [path] bad path element "~/.ivy2/cache/org.carrot2/morfologik-polish/jars/morfologik-fsa-1.5.3.jar": no such file or directory
         [javac] warning: [path] bad path element "~/.ivy2/cache/org.carrot2/morfologik-stemming/jars/morfologik-fsa-1.5.3.jar": no such file or directory
         [javac] warning: [path] bad path element "~/.ivy2/cache/org.carrot2/morfologik-fsa/jars/hppc-0.4.1.jar": no such file or directory
      i'm just doing
      <ivy:cachepath pathid="solr.path" log="download-only" type="bundle,jar" />
      
      1. SOLR-4106.patch
        7 kB
        Dawid Weiss
      2. solr4106.zip
        0.8 kB
        Dawid Weiss

        Activity

        Dawid Weiss added a comment -

        Works for me without a glitch. Can you try to reproduce the message you're seeing?

        Dawid Weiss added a comment -

        Wait... this is odd – if you really have ~ in your paths then javac won't be able to locate them because they're shell expansions, aren't they?

        Robert Muir added a comment -

        I think this is a simpler way to reproduce (or maybe a different bug alltogether):

        rmuir@beast:~/workspace/lucene-trunk/lucene$ ant test -Dtestcase=foo > test.log

        common.compile-core:
           [mkdir] Created dir: /home/rmuir/workspace/lucene-trunk/lucene/build/analysis/morfologik/classes/java
           [javac] Compiling 5 source files to /home/rmuir/workspace/lucene-trunk/lucene/build/analysis/morfologik/classes/java
           [javac] warning: [path] bad path element "/home/rmuir/workspace/lucene-trunk/lucene/analysis/morfologik/lib/hppc-0.4.1.jar": no such file or directory
           [javac] 1 warning
            [copy] Copying 1 file to /home/rmuir/workspace/lucene-trunk/lucene/build/analysis/morfologik/classes/java
        

        I looked into this, but i have no ideas yet what is causing this.

        Dawid Weiss added a comment -

        This is caused by a manifest classpath entry in morfologik-fsa-1.5.3.jar referencing HPPC (which is a dependency required for constructing automata, not for traversals etc.). Javac is issuing a warning even though this isn't explicitly on the classpath.

        Don't know what to do with it yet.

        Dawid Weiss added a comment -

        Seems to work for me fine after applying this patch.

        Commit Tag Bot added a comment -

        [branch_4x commit] Dawid Weiss
        http://svn.apache.org/viewvc?view=revision&revision=1428824

        SOLR-4106: Javac/ ivy path warnings with morfologik fixed by upgrading to Morfologik 1.5.5

        Commit Tag Bot added a comment -

        [trunk commit] Dawid Weiss
        http://svn.apache.org/viewvc?view=revision&revision=1428823

        SOLR-4106: Javac/ ivy path warnings with morfologik fixed by updating to Morfologik 1.5.5 (no functional changes).


          People

          • Assignee:
            Dawid Weiss
            Reporter:
            Dawid Weiss
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development